summaryrefslogtreecommitdiff
path: root/system/docbook-xsl/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-25 06:09:52 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-25 06:09:52 -0500
commit9ba7cee8a94a9ef8d1e87949bfdbdc4458d6b538 (patch)
tree713006b36e1b03f3b4ea559b59808f0f3f20f001 /system/docbook-xsl/APKBUILD
parent41248e0f93acf525137df8b42c0e00a5e4a5c773 (diff)
downloadpackages-9ba7cee8a94a9ef8d1e87949bfdbdc4458d6b538.tar.gz
packages-9ba7cee8a94a9ef8d1e87949bfdbdc4458d6b538.tar.bz2
packages-9ba7cee8a94a9ef8d1e87949bfdbdc4458d6b538.tar.xz
packages-9ba7cee8a94a9ef8d1e87949bfdbdc4458d6b538.zip
system/docbook-xsl: pull in for xmlto
Diffstat (limited to 'system/docbook-xsl/APKBUILD')
-rw-r--r--system/docbook-xsl/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/system/docbook-xsl/APKBUILD b/system/docbook-xsl/APKBUILD
new file mode 100644
index 000000000..0482a76ef
--- /dev/null
+++ b/system/docbook-xsl/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=docbook-xsl
+pkgver=1.79.1
+pkgrel=2
+pkgdesc="XML stylesheets for Docbook-xml transformations."
+url="http://docbook.sourceforge.net/"
+arch="noarch"
+options="!check" # Just XML files
+license="MIT"
+depends="libxml2-utils libxslt docbook-xml"
+makedepends=""
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
+source="http://downloads.sourceforge.net/sourceforge/docbook/$pkgname-$pkgver.tar.bz2
+ 765567_non-recursive_string_subst.patch
+ "
+
+package() {
+ cd "$builddir"
+ local _dest dir f
+ _dest="$pkgdir"/usr/share/xml/docbook/xsl-stylesheets-$pkgver
+
+ install -dm755 "$_dest"
+ install -m644 VERSION VERSION.xsl "$_dest"/
+
+ for dir in assembly common eclipse epub epub3 fo highlighting html \
+ htmlhelp javahelp lib manpages params profiling roundtrip \
+ template website xhtml xhtml-1_1 xhtml5; do
+
+ install -dm755 $_dest/$dir
+ for f in $dir/*.xml $dir/*.xsl $dir/*.dtd $dir/*.ent; do
+ [ -e "$f" ] || continue
+ install -m644 $f $_dest/$dir
+ done
+ done
+
+ install -dm755 "$pkgdir"/etc/xml
+
+ install -m644 -D COPYING \
+ "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+sha512sums="83325cbaf1545da6b9b8b77f5f0e6fdece26e3c455164b300a1aa3d19e3bd29ae71fd563553a714a5394968d1a65684c6c7987c77524469358d18b8c227025c7 docbook-xsl-1.79.1.tar.bz2
+6a26838078a3ce28273dddfa1af6a378cffc28b6d1ba48a4cfc839addd7bf58ce217d6584b735f9c75381954744ab2386c75fa3c593858b6e27882be55c00d04 765567_non-recursive_string_subst.patch"