summaryrefslogtreecommitdiff
path: root/system/gcc/020_all_msgfmt-libstdc++-link.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-20 21:53:51 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-20 21:54:20 -0600
commit6d7203982c05651f748825deb393eb6480c03e32 (patch)
treef771531d5103dede68a6c9f52b349d8ba04cbb09 /system/gcc/020_all_msgfmt-libstdc++-link.patch
parent866f81aaa5e438537e6a4b30c1f0fcecc713a1a2 (diff)
downloadpackages-6d7203982c05651f748825deb393eb6480c03e32.tar.gz
packages-6d7203982c05651f748825deb393eb6480c03e32.tar.bz2
packages-6d7203982c05651f748825deb393eb6480c03e32.tar.xz
packages-6d7203982c05651f748825deb393eb6480c03e32.zip
system/gcc: maintain our own toolchain
Diffstat (limited to 'system/gcc/020_all_msgfmt-libstdc++-link.patch')
-rw-r--r--system/gcc/020_all_msgfmt-libstdc++-link.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/system/gcc/020_all_msgfmt-libstdc++-link.patch b/system/gcc/020_all_msgfmt-libstdc++-link.patch
new file mode 100644
index 000000000..a70ea50a0
--- /dev/null
+++ b/system/gcc/020_all_msgfmt-libstdc++-link.patch
@@ -0,0 +1,39 @@
+Ensure that msgfmt doesn't encounter problems during gcc bootstrapping.
+
+Solves error messages like the following:
+
+msgfmt: /var/tmp/portage/sys-devel/gcc-4.1.2/work/build/./gcc/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/libstdc++.so.6)
+
+The libgcc_s.so used during build doesn't satisfy the needs of the
+libstdc++.so that msgfmt is linked against. On the other hand, msgfmt
+is used as a stand-alone application here, and what library it uses
+behind the scenes is of no concern to the gcc build process.
+Therefore, simply invoking it "as usual", i.e. without any special
+library path, will make it work as expected here.
+
+2011-09-19 Martin von Gagern
+
+References:
+https://bugs.gentoo.org/372377
+https://bugs.gentoo.org/295480
+
+--- gcc-4.1.2.orig/libstdc++-v3/po/Makefile.am
++++ gcc-4.1.2/libstdc++-v3/po/Makefile.am
+@@ -39,6 +39,7 @@ MSGFMT = msgfmt
+ EXTRA_DIST = string_literals.cc POTFILES.in $(PACKAGE).pot $(LOCALE_IN)
+
+ .po.mo:
++ env --unset=LD_LIBRARY_PATH \
+ $(MSGFMT) -o $@ $<
+
+ all-local: all-local-$(USE_NLS)
+--- gcc-4.1.2.orig/libstdc++-v3/po/Makefile.in
++++ gcc-4.1.2/libstdc++-v3/po/Makefile.in
+@@ -419,6 +419,7 @@ uninstall-am: uninstall-info-am
+
+
+ .po.mo:
++ env --unset=LD_LIBRARY_PATH \
+ $(MSGFMT) -o $@ $<
+
+ all-local: all-local-$(USE_NLS)