summaryrefslogtreecommitdiff
path: root/system/gcc
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-05-26 18:10:24 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-05-26 18:10:24 -0500
commit417fd74367e53ad30548b3ef403e17feb8c84708 (patch)
tree248fb716cfd98c0080ca792c10fc114bcd87a6e1 /system/gcc
parent0e6b566315c5c17a6753da009f268b10db06788e (diff)
downloadpackages-417fd74367e53ad30548b3ef403e17feb8c84708.tar.gz
packages-417fd74367e53ad30548b3ef403e17feb8c84708.tar.bz2
packages-417fd74367e53ad30548b3ef403e17feb8c84708.tar.xz
packages-417fd74367e53ad30548b3ef403e17feb8c84708.zip
system/gcc: add Cortex-A53 fixes to GCC (thanks @smaeul)
Diffstat (limited to 'system/gcc')
-rw-r--r--system/gcc/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/system/gcc/APKBUILD b/system/gcc/APKBUILD
index 5fa1e4e11..de4431f5b 100644
--- a/system/gcc/APKBUILD
+++ b/system/gcc/APKBUILD
@@ -234,7 +234,7 @@ build() {
cd "$_gccdir"
case "$CTARGET" in
- aarch64-*-*-*) _arch_configure="--with-arch=armv8-a --with-abi=lp64";;
+ aarch64-*-*-*) _arch_configure="--with-arch=armv8-a --with-abi=lp64 --enable-fix-cortex-a53-835769 --enable-fix-cortex-a53-843419";;
armv5-*-*-*eabi) _arch_configure="--with-arch=armv5te --with-tune=arm926ej-s --with-float=soft --with-abi=aapcs-linux";;
armv6-*-*-*eabihf) _arch_configure="--with-arch=armv6zk --with-tune=arm1176jzf-s --with-fpu=vfp --with-float=hard --with-abi=aapcs-linux";;
armv7-*-*-*eabihf) _arch_configure="--with-arch=armv7-a --with-tune=generic-armv7-a --with-fpu=vfpv3-d16 --with-float=hard --with-abi=aapcs-linux --with-mode=thumb";;