summaryrefslogtreecommitdiff
path: root/system/gettext-tiny
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-21 19:56:55 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-22 00:41:37 -0500
commit3a90a9469a33579c60320149a882aa8157814bfe (patch)
treef8f2c1447f0d1bba7726c5e39a2ca1e7c0be46f7 /system/gettext-tiny
parent1f1a1b12c8d5e8b5b6fbe66c62bde03f5932eaa5 (diff)
downloadpackages-3a90a9469a33579c60320149a882aa8157814bfe.tar.gz
packages-3a90a9469a33579c60320149a882aa8157814bfe.tar.bz2
packages-3a90a9469a33579c60320149a882aa8157814bfe.tar.xz
packages-3a90a9469a33579c60320149a882aa8157814bfe.zip
system/gettext-tiny: support C++
Diffstat (limited to 'system/gettext-tiny')
-rw-r--r--system/gettext-tiny/APKBUILD6
-rw-r--r--system/gettext-tiny/cpp-compat.patch22
2 files changed, 26 insertions, 2 deletions
diff --git a/system/gettext-tiny/APKBUILD b/system/gettext-tiny/APKBUILD
index ce3d9b1de..e78ccbb4d 100644
--- a/system/gettext-tiny/APKBUILD
+++ b/system/gettext-tiny/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gettext-tiny
pkgver=0.3.0_pre1
-pkgrel=0
+pkgrel=1
pkgdesc="An internationalisation and localisation system"
url="https://github.com/sabotage-linux/gettext-tiny"
arch="all"
@@ -16,6 +16,7 @@ source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz
omg-i-cant-believe-im-doing-ua-crap.patch
respect-cflags.patch
stop-doing-macro-crap.patch
+ cpp-compat.patch
"
build() {
@@ -31,4 +32,5 @@ package() {
sha512sums="3795b9923f6820ce6e2c6a27480365a4ee1cb1f8f8916256887a40c8e0f0b582ada049a528330297f8daa1bff7d5877a15169095332456c57dc3fdb49407ef98 gettext-tiny-0.3.0_pre1.tar.xz
afb9afd32bf3bb276da5dccd582bd4bba1a1baaa445e08fb88da5690abdb9b267f2452e9189aee89436aa8e3c685465d7368804b90395eb7bd66874cab7711e6 omg-i-cant-believe-im-doing-ua-crap.patch
cea1596f3f20c8983e57d2e49e955a43ed2e261b244f6c4c2ae7d8b869e3cfce3bb87b0a17c16bdac59afd99703cef9c7ef4e93fca536bf1bf9aa5f9be9fa34f respect-cflags.patch
-d2a1a6b1f135c25172cf98dfed64739ff85f6016a31c3ce028b3a7aa72de0b55c1f9a54c5ba2c58817f5222c3d2a5bc3d03ec9058ae5fbae2c798df9227a4e52 stop-doing-macro-crap.patch"
+d2a1a6b1f135c25172cf98dfed64739ff85f6016a31c3ce028b3a7aa72de0b55c1f9a54c5ba2c58817f5222c3d2a5bc3d03ec9058ae5fbae2c798df9227a4e52 stop-doing-macro-crap.patch
+0f1a1be10a038e6d30976f060c271e926f8f6b0541af7044f1b0ac2641825fc784ce3e3ff6ca13f3a5d15bbcd355a0999b60d4aa6f30c7b75254ca0edcaccc4d cpp-compat.patch"
diff --git a/system/gettext-tiny/cpp-compat.patch b/system/gettext-tiny/cpp-compat.patch
new file mode 100644
index 000000000..e47c59695
--- /dev/null
+++ b/system/gettext-tiny/cpp-compat.patch
@@ -0,0 +1,22 @@
+--- gettext-tiny-0.3.0_pre1/include/libintl.h.old 2018-06-21 19:55:29.646162973 -0500
++++ gettext-tiny-0.3.0_pre1/include/libintl.h 2018-06-21 19:56:16.886116203 -0500
+@@ -1,6 +1,9 @@
+ #ifndef LIBINTL_H
+ #define LIBINTL_H
+
++#ifdef __cplusplus
++extern "C" {
++#endif
+ char *gettext(const char *msgid);
+ char *dgettext(const char *domainname, const char *msgid);
+ char *dcgettext(const char *domainname, const char *msgid, int category);
+@@ -11,6 +14,9 @@
+ char *textdomain(const char *domainname);
+ char *bind_textdomain_codeset(const char *domainname, const char *codeset);
+ char *bindtextdomain(const char *domainname, const char *dirname);
++#ifdef __cplusplus
++}
++#endif
+
+ #undef gettext_noop
+ #define gettext_noop(X) X