summaryrefslogtreecommitdiff
path: root/system/gettext-tiny
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-11 20:26:19 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-11 20:26:19 -0500
commitb0785d33c0e284959e3317b0a2839c509a2f36fc (patch)
tree7e56290163f1a88961ea6e581d421dc3ced0e74d /system/gettext-tiny
parent345e5a8b2c9aff44eaf699eed18b1b3066d35d05 (diff)
downloadpackages-b0785d33c0e284959e3317b0a2839c509a2f36fc.tar.gz
packages-b0785d33c0e284959e3317b0a2839c509a2f36fc.tar.bz2
packages-b0785d33c0e284959e3317b0a2839c509a2f36fc.tar.xz
packages-b0785d33c0e284959e3317b0a2839c509a2f36fc.zip
system/gettext-tiny: workaround issue that makes GConf fail
Diffstat (limited to 'system/gettext-tiny')
-rw-r--r--system/gettext-tiny/APKBUILD6
-rw-r--r--system/gettext-tiny/double-stack-size.patch20
2 files changed, 24 insertions, 2 deletions
diff --git a/system/gettext-tiny/APKBUILD b/system/gettext-tiny/APKBUILD
index 01d49b225..fa430d70a 100644
--- a/system/gettext-tiny/APKBUILD
+++ b/system/gettext-tiny/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=gettext-tiny
pkgver=0.3.0_pre1
-pkgrel=3
+pkgrel=4
pkgdesc="An internationalisation and localisation system"
url="https://github.com/sabotage-linux/gettext-tiny"
arch="all"
@@ -17,6 +17,7 @@ source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz
respect-cflags.patch
stop-doing-macro-crap.patch
cpp-compat.patch
+ double-stack-size.patch
"
build() {
@@ -33,4 +34,5 @@ sha512sums="3795b9923f6820ce6e2c6a27480365a4ee1cb1f8f8916256887a40c8e0f0b582ada0
2951ad99fd04ee7d8dc06b4de575b7838e350737e3b40ecd93eae9f6f2b4c15883a392370e25dfaf834a57bc801721894e946d24910cfd65c44c2e025321ade4 omg-i-cant-believe-im-doing-ua-crap.patch
cea1596f3f20c8983e57d2e49e955a43ed2e261b244f6c4c2ae7d8b869e3cfce3bb87b0a17c16bdac59afd99703cef9c7ef4e93fca536bf1bf9aa5f9be9fa34f respect-cflags.patch
d2a1a6b1f135c25172cf98dfed64739ff85f6016a31c3ce028b3a7aa72de0b55c1f9a54c5ba2c58817f5222c3d2a5bc3d03ec9058ae5fbae2c798df9227a4e52 stop-doing-macro-crap.patch
-0f1a1be10a038e6d30976f060c271e926f8f6b0541af7044f1b0ac2641825fc784ce3e3ff6ca13f3a5d15bbcd355a0999b60d4aa6f30c7b75254ca0edcaccc4d cpp-compat.patch"
+0f1a1be10a038e6d30976f060c271e926f8f6b0541af7044f1b0ac2641825fc784ce3e3ff6ca13f3a5d15bbcd355a0999b60d4aa6f30c7b75254ca0edcaccc4d cpp-compat.patch
+d5227a56fd136a00832ad224675e333cb8a686415a45485bd02406a2cefa13ef5698b6790ee23bac05d5ad43d4d01657c17c663bf578e4d7681451a25f800618 double-stack-size.patch"
diff --git a/system/gettext-tiny/double-stack-size.patch b/system/gettext-tiny/double-stack-size.patch
new file mode 100644
index 000000000..89f2f82f3
--- /dev/null
+++ b/system/gettext-tiny/double-stack-size.patch
@@ -0,0 +1,20 @@
+Seen in the Dzongkha translation of GConf 3.2.6:
+
+ /bin/sh: line 1: 25453 Aborted /usr/bin/msgfmt -o $file dz.po
+
+This is what we expect to see having a short read of the line; the line in
+question is 4,279 bytes long.
+
+--- gettext-tiny-0.3.0_pre1/src/msgfmt.c.old 2018-06-21 04:47:19.927932643 +0000
++++ gettext-tiny-0.3.0_pre1/src/msgfmt.c 2018-07-12 01:23:59.250000000 +0000
+@@ -370,8 +370,8 @@
+
+ int process(FILE *in, FILE *out) {
+ struct mo_hdr mohdr = def_hdr;
+- char line[4096]; char *lp;
+- char convbuf[16384];
++ char line[8192]; char *lp;
++ char convbuf[32768];
+
+ struct callbackdata d = {
+ .num = {