summaryrefslogtreecommitdiff
path: root/system/git/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-08 01:09:12 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-08 01:09:12 +0000
commit87848d4a5fd8269cda1b0ae5e1dcf22cadf307b3 (patch)
tree66ea747525a1a32d483465cfdf0fc00eadc74e1b /system/git/APKBUILD
parent9b6e27621bb9b11ca6f226a735802b68126b792a (diff)
downloadpackages-87848d4a5fd8269cda1b0ae5e1dcf22cadf307b3.tar.gz
packages-87848d4a5fd8269cda1b0ae5e1dcf22cadf307b3.tar.bz2
packages-87848d4a5fd8269cda1b0ae5e1dcf22cadf307b3.tar.xz
packages-87848d4a5fd8269cda1b0ae5e1dcf22cadf307b3.zip
system/git: bump to 2.21.0, fix patch, modernise
Diffstat (limited to 'system/git/APKBUILD')
-rw-r--r--system/git/APKBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/system/git/APKBUILD b/system/git/APKBUILD
index 84f3196c7..e931dce98 100644
--- a/system/git/APKBUILD
+++ b/system/git/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=git
-pkgver=2.19.2
+pkgver=2.21.0
pkgrel=0
pkgdesc="A distributed version control system"
url="https://www.git-scm.com/"
@@ -36,9 +36,7 @@ source="https://www.kernel.org/pub/software/scm/git/git-$pkgver.tar.xz
git-daemon.initd
git-daemon.confd
"
-
_gitcoredir=/usr/libexec/git-core
-builddir="$srcdir"/$pkgname-$pkgver
prepare() {
default_prepare
@@ -55,18 +53,15 @@ prepare() {
}
build() {
- cd "$builddir"
make prefix=/usr DESTDIR="$pkgdir"
}
check() {
- cd "$builddir"
rm t/t9020-remote-svn.sh # Requires /usr/bin/python / python-compat.
make prefix=/usr DESTDIR="$pkgdir" -j1 test
}
package() {
- cd "$builddir"
make -j1 prefix=/usr \
DESTDIR="$pkgdir" \
INSTALLDIRS=vendor \
@@ -169,7 +164,7 @@ subtree_doc() {
gzip -9 "$subpkgdir"/usr/share/man/man1/git-subtree.1
}
-sha512sums="1d707c1a7a16fe9399592b0354e9023f701b019f36fe775997c46354d40617a80fa04aacc5330825c4f9301c2910ead8b26274a7f3b92e9d790b4705c0d7aa96 git-2.19.2.tar.xz
-ef6c31ac1474fa128aecf86eda75653fdd0fe7a09d35914c1a03749abf9c92cbc01f8064b2b697ca796fa18bec717b9bcb1aac6d36d02ce8ed4270d4728e72f0 dont-test-other-encodings.patch
+sha512sums="83f57c3950a07f6773a3aea66611d22daba0e5599e5d8f0751a16f6fdbeab0f3844d942a39a5642051212df99d1d4513253c36829b1454b4f0977cc6026fd973 git-2.21.0.tar.xz
+315e4666c425b31a7f7a447e777cbf2a1050feac9b4d4b8a61c05248024e790d4d18f3336faf2a2c68584e05e8194c22a09e1caba1352cfec194e0bc01277a6c dont-test-other-encodings.patch
89528cdd14c51fd568aa61cf6c5eae08ea0844e59f9af9292da5fc6c268261f4166017d002d494400945e248df6b844e2f9f9cd2d9345d516983f5a110e4c42a git-daemon.initd
fbf1f425206a76e2a8f82342537ed939ff7e623d644c086ca2ced5f69b36734695f9f80ebda1728f75a94d6cd2fcb71bf845b64239368caab418e4d368c141ec git-daemon.confd"