summaryrefslogtreecommitdiff
path: root/system/gmp/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /system/gmp/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'system/gmp/APKBUILD')
-rw-r--r--system/gmp/APKBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/system/gmp/APKBUILD b/system/gmp/APKBUILD
index 69f4b2c9c..ab8f1b70b 100644
--- a/system/gmp/APKBUILD
+++ b/system/gmp/APKBUILD
@@ -6,21 +6,19 @@ pkgdesc="A free library for arbitrary precision arithmetic"
url="https://gmplib.org/"
arch="all"
license="LGPL-3.0+ OR GPL-2.0+"
+depends=""
makedepends="m4 texinfo libtool"
-depends=
subpackages="$pkgname-doc $pkgname-dev libgmpxx"
source="https://gmplib.org/download/gmp/gmp-$pkgver.tar.xz
"
prepare() {
- cd "$builddir"
default_prepare
# force update to libtool with fixed cross-build support
libtoolize -f
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,12 +33,10 @@ build() {
}
package() {
- cd "$builddir"
make -j1 DESTDIR="${pkgdir}" install
}
check() {
- cd "$builddir"
[ "$CBUILD" = "$CHOST" ] && make check
}