summaryrefslogtreecommitdiff
path: root/system/libcap-ng
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-14 02:22:19 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-14 02:22:56 -0500
commitb1eb50599e4db7eb4501af75cbbfa22007081ea5 (patch)
treec94a34c882cc17adedd781e8c5f34349b2a62416 /system/libcap-ng
parentb9e85bbdcf38547ef2ca4e5c2a6e6293bbcd2752 (diff)
downloadpackages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.tar.gz
packages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.tar.bz2
packages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.tar.xz
packages-b1eb50599e4db7eb4501af75cbbfa22007081ea5.zip
The New Plan
all pkgs needed to bootstrap -> system others -> user
Diffstat (limited to 'system/libcap-ng')
-rw-r--r--system/libcap-ng/APKBUILD48
-rw-r--r--system/libcap-ng/fix-includes.patch11
2 files changed, 59 insertions, 0 deletions
diff --git a/system/libcap-ng/APKBUILD b/system/libcap-ng/APKBUILD
new file mode 100644
index 000000000..a1503aeda
--- /dev/null
+++ b/system/libcap-ng/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libcap-ng
+pkgver=0.7.8
+pkgrel=1
+pkgdesc="posix capabilities library"
+url="http://people.redhat.com/sgrubb/libcap-ng/index.html"
+arch="all"
+license="GPL"
+depends_dev="linux-headers"
+makedepends="python3 $depends_dev"
+makedepends_host="$depends_dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-utils"
+source="http://people.redhat.com/sgrubb/libcap-ng/libcap-ng-$pkgver.tar.gz
+ fix-includes.patch
+ "
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+utils() {
+ pkgdesc="posix capabilities utils"
+
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/* "$subpkgdir"/usr/bin/
+}
+
+sha512sums="c32a4c5780c183b13611615abe9061221fd8987188b08828d1617cdaee338ad8de67b3430aa83bde60128efc76449a688546bfbf697f0847b6a835cb1a868756 libcap-ng-0.7.8.tar.gz
+8de98ce0fae63812cf7fd17e788343798b0cab63ba029f046ac9b89b2305da17432bafdd3dfa36046fc2cc0a453e0c889f6744c632f4617e0e5fc08e2823e324 fix-includes.patch"
diff --git a/system/libcap-ng/fix-includes.patch b/system/libcap-ng/fix-includes.patch
new file mode 100644
index 000000000..8fbd984b8
--- /dev/null
+++ b/system/libcap-ng/fix-includes.patch
@@ -0,0 +1,11 @@
+diff -ru libcap-ng-0.7.4.orig/src/cap-ng.c libcap-ng-0.7.4/src/cap-ng.c
+--- libcap-ng-0.7.4.orig/src/cap-ng.c 2014-04-24 15:41:43.000000000 -0300
++++ libcap-ng-0.7.4/src/cap-ng.c 2015-04-15 08:45:10.783335463 -0300
+@@ -34,6 +34,7 @@
+ #include <stdarg.h>
+ #include <errno.h>
+ #include <fcntl.h>
++#include <endian.h>
+ #include <byteswap.h>
+ #ifdef HAVE_SYSCALL_H
+ #include <sys/syscall.h>