summaryrefslogtreecommitdiff
path: root/system/libxml2
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-24 23:27:00 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-06-24 23:27:00 -0500
commit2ec0ab2f3bc874598e8be7fd25396cd3ba45ef67 (patch)
tree87f365f1855592f99259b04d3f372c0cde34150e /system/libxml2
parentf575bc2f7949e2f3a2b3135f2db5e7f58e5ef65e (diff)
downloadpackages-2ec0ab2f3bc874598e8be7fd25396cd3ba45ef67.tar.gz
packages-2ec0ab2f3bc874598e8be7fd25396cd3ba45ef67.tar.bz2
packages-2ec0ab2f3bc874598e8be7fd25396cd3ba45ef67.tar.xz
packages-2ec0ab2f3bc874598e8be7fd25396cd3ba45ef67.zip
system/libxml2: [PD] take, bump to 2.9.8, remove old patch
Diffstat (limited to 'system/libxml2')
-rw-r--r--system/libxml2/APKBUILD12
-rw-r--r--system/libxml2/libxml2-2.9.4-remove-pyverify_fd.patch12
2 files changed, 5 insertions, 19 deletions
diff --git a/system/libxml2/APKBUILD b/system/libxml2/APKBUILD
index 8f7207c16..8630b9445 100644
--- a/system/libxml2/APKBUILD
+++ b/system/libxml2/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libxml2
-pkgver=2.9.7
-pkgrel=2
-pkgdesc="XML parsing library, version 2"
+pkgver=2.9.8
+pkgrel=0
+pkgdesc="XML parsing library"
url="http://www.xmlsoft.org/"
arch="all"
license="MIT"
@@ -14,7 +14,6 @@ makedepends="$depends_dev python3-dev"
subpackages="$pkgname-doc $pkgname-dev $pkgname-utils py-libxml2:py"
options="!check !strip" # Impossible to run on Python 3
source="ftp://ftp.xmlsoft.org/${pkgname}/${pkgname}-${pkgver}.tar.gz
- libxml2-2.9.4-remove-pyverify_fd.patch
python-segfault-fix.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -72,6 +71,5 @@ utils() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="da06cb7c5032ef4b7c8e902fabb9d2c74634c42c161be07a7c66a00d53a68029f89b0d4de32a6b9d4ff338c2d1d9c4e53aefb9cf50cb1c2d6c6b06b442ef42d5 libxml2-2.9.7.tar.gz
-271e701daf08f10a8b591c5128f596105901a29ecc9ee72f088afab266eaec7932a4a7d2194baa07c69e1aa93f3e9dc01a4a890456f53416c45d490598be41d9 libxml2-2.9.4-remove-pyverify_fd.patch
+sha512sums="28903282c7672206effa1362fd564cbe4cf5be44264b083a7d14e383f73bccd1b81bcafb5f4f2f56f5e7e05914c660e27668c9ce91b1b9f256ef5358d55ba917 libxml2-2.9.8.tar.gz
384b3d2031cd8f77528190bbb7652faa9ccb22bc604bcf4927e59046d38830dac38010828fe1568b6514976f725981a6d3ac1aa595d31477a36db2afe491452c python-segfault-fix.patch"
diff --git a/system/libxml2/libxml2-2.9.4-remove-pyverify_fd.patch b/system/libxml2/libxml2-2.9.4-remove-pyverify_fd.patch
deleted file mode 100644
index d05d4cb60..000000000
--- a/system/libxml2/libxml2-2.9.4-remove-pyverify_fd.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur libxml2-2.9.4.orig/python/types.c libxml2-2.9.4/python/types.c
---- libxml2-2.9.4.orig/python/types.c 2016-02-09 03:17:33.000000000 -0700
-+++ libxml2-2.9.4/python/types.c 2016-12-21 12:34:06.755650986 -0700
-@@ -31,8 +31,6 @@
- const char *mode;
-
- fd = PyObject_AsFileDescriptor(f);
-- if (!_PyVerify_fd(fd))
-- return(NULL);
- /*
- * Get the flags on the fd to understand how it was opened
- */