summaryrefslogtreecommitdiff
path: root/system/linenoise/build-shared-lib.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-29 16:05:33 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-29 16:05:33 -0500
commit9d1a7b2bf11b16b3b5aa2a3c09f00588cf4a7cdf (patch)
tree2e23088c6630a97c89ef77f2a130aa9907422a6e /system/linenoise/build-shared-lib.patch
parent4b6bbcad502d5e2299df4cb4f8d79297b4ea0ce7 (diff)
downloadpackages-9d1a7b2bf11b16b3b5aa2a3c09f00588cf4a7cdf.tar.gz
packages-9d1a7b2bf11b16b3b5aa2a3c09f00588cf4a7cdf.tar.bz2
packages-9d1a7b2bf11b16b3b5aa2a3c09f00588cf4a7cdf.tar.xz
packages-9d1a7b2bf11b16b3b5aa2a3c09f00588cf4a7cdf.zip
system/linenoise: Don't call ldconfig(8) for .so
We do not need to add the build path to the ld path. Fixes: #753
Diffstat (limited to 'system/linenoise/build-shared-lib.patch')
-rw-r--r--system/linenoise/build-shared-lib.patch3
1 files changed, 1 insertions, 2 deletions
diff --git a/system/linenoise/build-shared-lib.patch b/system/linenoise/build-shared-lib.patch
index b94d6ab4c..12a98edda 100644
--- a/system/linenoise/build-shared-lib.patch
+++ b/system/linenoise/build-shared-lib.patch
@@ -1,6 +1,6 @@
--- ./Makefile.orig
+++ ./Makefile
-@@ -1,7 +1,34 @@
+@@ -1,7 +1,33 @@
+MAJOR_VERSION = 0
+EXTRA_VERSION = .0.0
+SONAME = liblinenoise.so.$(MAJOR_VERSION)
@@ -33,6 +33,5 @@
+ install -m 0644 linenoise.h $(DESTDIR)$(INCLUDEDIR)
+ install -m 0755 -d $(DESTDIR)$(LIBDIR)
+ install -m 0755 $(LIB) $(DESTDIR)$(LIBDIR)
-+ ldconfig -n $(DESTDIR)$(LIBDIR)
+ ln -s $(LIB) $(DESTDIR)$(LIBDIR)/$(SONAME)
+ ln -s $(SONAME) $(DESTDIR)$(LIBDIR)/liblinenoise.so