summaryrefslogtreecommitdiff
path: root/system/lua5.3/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 01:00:56 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-21 01:00:56 +0000
commit9a841fe2af5204c11e54bdb00a8f46088b30de7d (patch)
treec036b83ca4ac76a15eaa4c833523abddbcd290d4 /system/lua5.3/APKBUILD
parent7833fcbe0f814b7ca0ea9bf5da6d0381de9c7d10 (diff)
downloadpackages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.tar.gz
packages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.tar.bz2
packages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.tar.xz
packages-9a841fe2af5204c11e54bdb00a8f46088b30de7d.zip
system/l*: modernise, fix metadata, etc
Diffstat (limited to 'system/lua5.3/APKBUILD')
-rw-r--r--system/lua5.3/APKBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/system/lua5.3/APKBUILD b/system/lua5.3/APKBUILD
index 9a90fc7c9..859a7a05b 100644
--- a/system/lua5.3/APKBUILD
+++ b/system/lua5.3/APKBUILD
@@ -4,11 +4,12 @@ _pkgname=lua
pkgver=5.3.5
_luaver=${pkgname#lua}
pkgrel=1
-pkgdesc="Light-weight programming language"
+pkgdesc="Embeddable programming language"
url="https://www.lua.org/"
arch="all"
license="MIT"
ldpath="/usr/lib/$pkgname"
+depends=""
depends_dev="$pkgname"
makedepends="libtool autoconf automake linenoise-dev"
provides="lua"
@@ -27,7 +28,6 @@ builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
# disable readline
sed -i '/#define LUA_USE_READLINE/d' src/luaconf.h
@@ -44,8 +44,6 @@ prepare() {
}
build() {
- cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -61,22 +59,18 @@ build() {
}
check() {
- cd "$builddir"
make test
}
package() {
- local i
- cd "$builddir"
-
make V=${pkgver%.*} \
INSTALL_TOP="$pkgdir"/usr \
INSTALL_INC="$pkgdir"/usr/include/$pkgname \
INSTALL_LIB="$pkgdir"/usr/lib/$pkgname \
alpine_install
- for i in "$pkgdir"/usr/lib/$pkgname/*.so.*; do
- ln -s $pkgname/${i##*/} "$pkgdir"/usr/lib/${i##*/}
+ for $_solib in "$pkgdir"/usr/lib/$pkgname/*.so.*; do
+ ln -s $pkgname/${_solib##*/} "$pkgdir"/usr/lib/${_solib##*/}
done
install -D -m 644 doc/lua.1 "$pkgdir"/usr/share/man/man1/lua.1