summaryrefslogtreecommitdiff
path: root/system/m4
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-02-09 03:30:22 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-05-01 17:05:51 -0500
commit0628acecccc4440e667cb44e80b7033a31324c10 (patch)
treef2d37128a0da467561d95c5a3a728b07593e462d /system/m4
parent13566a2f988c3c800a5e1651e248969e37c1e1d0 (diff)
downloadpackages-0628acecccc4440e667cb44e80b7033a31324c10.tar.gz
packages-0628acecccc4440e667cb44e80b7033a31324c10.tar.bz2
packages-0628acecccc4440e667cb44e80b7033a31324c10.tar.xz
packages-0628acecccc4440e667cb44e80b7033a31324c10.zip
system/m4: Fix build with musl 1.2.3. Fixes #510.
Diffstat (limited to 'system/m4')
-rw-r--r--system/m4/APKBUILD4
-rw-r--r--system/m4/posix-test.patch18
2 files changed, 21 insertions, 1 deletions
diff --git a/system/m4/APKBUILD b/system/m4/APKBUILD
index 7dcd26271..130e290b8 100644
--- a/system/m4/APKBUILD
+++ b/system/m4/APKBUILD
@@ -14,6 +14,7 @@ source="https://ftp.gnu.org/gnu/m4/$pkgname-$pkgver.tar.gz
disable-mbrtowc-test.patch
gnulib-tests-dont-require-gpg-passphrase.patch
m4-1.4.19-test-198.patch
+ posix-test.patch
"
build() {
@@ -37,4 +38,5 @@ package() {
sha512sums="f5dd0f02fcae65a176a16af9a8e1747c26e9440c6c224003ba458d3298b777a75ffb189aee9051fb0c4840b2a48278be4a51d959381af0b1d627570f478c58f2 m4-1.4.19.tar.gz
c39562852502282f83b9bfa46aff00c8859b19d4d4335dbdb488748b10f6df6a13ea8291784683bf967674a5a824276419af47d2395e8af18823452a8d4999da disable-mbrtowc-test.patch
fb7344bc8a7aea1f1ce87474109aaf3d5a5ca0cd86b517025c6aad9a388a9ede7c267e7095d171d8768d1c0f0d9d8009e307467352afa81484c54dc476db0ebd gnulib-tests-dont-require-gpg-passphrase.patch
-f409fcfd70d55c099bba7d784bea8f99cd6ccbfe24dfc3d76a2e757df96b6c71f7e4b42f63d433259e3bec7b7e40e6569533c032c98537003a6e7314754dd6fb m4-1.4.19-test-198.patch"
+f409fcfd70d55c099bba7d784bea8f99cd6ccbfe24dfc3d76a2e757df96b6c71f7e4b42f63d433259e3bec7b7e40e6569533c032c98537003a6e7314754dd6fb m4-1.4.19-test-198.patch
+43c68f84c465b2e26a73ef0a5cf9bacafee70849f9de166eef45d7699438dce0ea3cacdd513daa8a8ae7fb677778290e2a78d01b551d9465de68eb167abcbc93 posix-test.patch"
diff --git a/system/m4/posix-test.patch b/system/m4/posix-test.patch
new file mode 100644
index 000000000..058c85c6f
--- /dev/null
+++ b/system/m4/posix-test.patch
@@ -0,0 +1,18 @@
+This behaviour does not pass on *this* platform.
+
+--- m4-1.4.19/tests/test-posix_spawn_file_actions_addclose.c.old 2021-04-22 15:28:47.000000000 -0500
++++ m4-1.4.19/tests/test-posix_spawn_file_actions_addclose.c 2022-02-09 03:27:59.030000000 -0600
+@@ -54,13 +54,6 @@
+ errno = 0;
+ ASSERT (posix_spawn_file_actions_addclose (&actions, -1) == EBADF);
+ }
+- /* This behaviour is not mandated by POSIX, but happens to pass on all
+- platforms. */
+- {
+- int bad_fd = big_fd ();
+- errno = 0;
+- ASSERT (posix_spawn_file_actions_addclose (&actions, bad_fd) == EBADF);
+- }
+
+ posix_spawn_file_actions_destroy (&actions);
+