summaryrefslogtreecommitdiff
path: root/system/musl
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-23 02:10:16 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-23 02:10:16 +0000
commite3952dc99438e145bc33b012c255ae0a8479685e (patch)
tree4b33e65fb3e9ae45cad826d75db09a0a2acd9a74 /system/musl
parenteab6b245665bb6928d6b540a7404885bb288d78e (diff)
downloadpackages-e3952dc99438e145bc33b012c255ae0a8479685e.tar.gz
packages-e3952dc99438e145bc33b012c255ae0a8479685e.tar.bz2
packages-e3952dc99438e145bc33b012c255ae0a8479685e.tar.xz
packages-e3952dc99438e145bc33b012c255ae0a8479685e.zip
system/musl: bump to 1.2.0_alpha3
Diffstat (limited to 'system/musl')
-rw-r--r--system/musl/APKBUILD6
-rw-r--r--system/musl/uapi-iphdr.patch30
2 files changed, 2 insertions, 34 deletions
diff --git a/system/musl/APKBUILD b/system/musl/APKBUILD
index 0758f513a..c2eb3303f 100644
--- a/system/musl/APKBUILD
+++ b/system/musl/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=musl
-pkgver=1.2.0_alpha2
+pkgver=1.2.0_alpha3
pkgrel=0
pkgdesc="System library (libc) implementation"
url="https://www.musl-libc.org/"
@@ -26,7 +26,6 @@ source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz
3001-make-real-lastlog-h.patch
handle-aux-at_base.patch
fgetspent_r.patch
- uapi-iphdr.patch
ldconfig
getent.c
@@ -117,12 +116,11 @@ utils() {
install -D -m755 "$srcdir"/ldconfig "$subpkgdir"/sbin
}
-sha512sums="3976257352ada259fe9baa31bb7d0193765d4e9d6583503543af0122d02fa75e5b5f9e5fee6b6f2550959a389eec3cc45e54eae9ccd08b7d5601c1207d367de1 musl-1.2.0_alpha2.tar.xz
+sha512sums="86b42aa86a08699cc5139fca7d2420da5ad3fc31f18454bd6167ad09b9ca69e2122657b7572f6bc1b68393df9756b9b6d2f8c1685e6e4aa170a8c04da32d1cbc musl-1.2.0_alpha3.tar.xz
f01ab92b9d385c15369c0bb7d95e1bc06a009c8851e363517d0ba1bae3fc2647af69fc2f363b5d962d376c5d9a1994b5728fd88ccbfff5f0d3d0970a02df1512 amalgamation.patch
88ae443dbb8e0a4368235bdc3a1c5c7b718495afa75e06deb8e01becc76cb1f0d6964589e2204fc749c9c1b3190b8b9ac1ae2c0099cab8e2ce3ec877103d4332 3001-make-real-lastlog-h.patch
6a7ff16d95b5d1be77e0a0fbb245491817db192176496a57b22ab037637d97a185ea0b0d19da687da66c2a2f5578e4343d230f399d49fe377d8f008410974238 handle-aux-at_base.patch
ded41235148930f8cf781538f7d63ecb0c65ea4e8ce792565f3649ee2523592a76b2a166785f0b145fc79f5852fd1fb1729a7a09110b3b8f85cba3912e790807 fgetspent_r.patch
-3b3866a32321cf72b72470230b88cde6bfc9f63e6ec33fef6023286b5733f90feed32b65b82d59ec353deb2ee199c1c95825802d7588019bf016b39d327f3c73 uapi-iphdr.patch
cb71d29a87f334c75ecbc911becde7be825ab30d8f39fa6d64cb53812a7c9abaf91d9804c72540e5be3ddd3c84cfe7fd9632274309005cb8bcdf9a9b09b4b923 ldconfig
378d70e65bcc65bb4e1415354cecfa54b0c1146dfb24474b69e418cdbf7ad730472cd09f6f103e1c99ba6c324c9560bccdf287f5889bbc3ef0bdf0e08da47413 getent.c
9d42d66fb1facce2b85dad919be5be819ee290bd26ca2db00982b2f8e055a0196290a008711cbe2b18ec9eee8d2270e3b3a4692c5a1b807013baa5c2b70a2bbf iconv.c"
diff --git a/system/musl/uapi-iphdr.patch b/system/musl/uapi-iphdr.patch
deleted file mode 100644
index 8483ca306..000000000
--- a/system/musl/uapi-iphdr.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 7e690371dbc52b0f771bc7cdecdb757d5e1a4c11 Mon Sep 17 00:00:00 2001
-From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
-Date: Sun, 22 Dec 2019 00:04:28 -0600
-Subject: [PATCH] netinet/ip.h: Add UAPI definition guard for iphdr
-
-This ensures that the musl definition of 'struct iphdr' does not conflict
-with the Linux kernel UAPI definition of it.
-
-Some software, i.e. net-tools, will not compile against 5.4 kernel headers
-without this patch and the corresponding Linux kernel patch.
----
- include/netinet/ip.h | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/include/netinet/ip.h b/include/netinet/ip.h
-index 8b6d7fef..0ae132a5 100644
---- a/include/netinet/ip.h
-+++ b/include/netinet/ip.h
-@@ -190,6 +190,8 @@ struct ip_timestamp {
-
- #define IP_MSS 576
-
-+#define __UAPI_DEF_IPHDR 0
-+
- #ifdef __cplusplus
- }
- #endif
---
-2.22.1
-