summaryrefslogtreecommitdiff
path: root/system/parted
diff options
context:
space:
mode:
authorSamuel Holland <samuel@sholland.org>2019-08-05 01:18:12 +0000
committerSamuel Holland <samuel@sholland.org>2019-08-05 01:18:12 +0000
commitafd97aad8dc1b39b6f4aa3be2adaef229aebf71e (patch)
treecd56c74058f04c04dbd4070996ae7009d0b07d3b /system/parted
parent80332505cb5ffb75c400ca02bfd80deed7d09f5a (diff)
downloadpackages-afd97aad8dc1b39b6f4aa3be2adaef229aebf71e.tar.gz
packages-afd97aad8dc1b39b6f4aa3be2adaef229aebf71e.tar.bz2
packages-afd97aad8dc1b39b6f4aa3be2adaef229aebf71e.tar.xz
packages-afd97aad8dc1b39b6f4aa3be2adaef229aebf71e.zip
system/parted: Fix build for major/minor move
Signed-off-by: Samuel Holland <samuel@sholland.org>
Diffstat (limited to 'system/parted')
-rw-r--r--system/parted/APKBUILD2
-rw-r--r--system/parted/sysmacros.patch10
2 files changed, 12 insertions, 0 deletions
diff --git a/system/parted/APKBUILD b/system/parted/APKBUILD
index ff9eb6c76..6f0e135ea 100644
--- a/system/parted/APKBUILD
+++ b/system/parted/APKBUILD
@@ -15,6 +15,7 @@ source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
disable-two-tests.patch
fix-includes.patch
fix-libintl-header-s390x.patch
+ sysmacros.patch
tests-call-name-correctly.patch
tests-python3.patch
"
@@ -50,5 +51,6 @@ sha512sums="4e37dbdd6f5032c9ebfec43704f6882379597d038167b9c4d04053efa083c68a7051
b49eb0211c405a4ef69e1bb0079621c22fec4adf0309f0a58b5d881540913de01d05ccd3eb521f35c3cf6f4eb8aa0f4c5270ce3dea47270a5c3fe8fae635c6f0 disable-two-tests.patch
55ee63c218d1867c0f2c596e7c3eec5c42af160181456cc551fe3d432eabed0ac2dd3a3955ff0c375f76aeec8071e7f55a32834b87a0d39b8ef30361f671bfdd fix-includes.patch
444a7e2fb3235dfd218f6b71fb25adde107d001f638d988ee1fa79686d8efee94a9499e27bdfdd75f9718760b448938b70a90a74285b93a39338d21f4ab4c9dc fix-libintl-header-s390x.patch
+5d2e8f22b6cd5bdd3289996848279a945ca09acd2862e82283bb769c2e4d61a24a31e1793d81385e8f3f1f4d48417e2308c5ea39dac47e832666363dde044ba7 sysmacros.patch
8bd86d2b0401566e7757c43d849b7f913cc4ec1bf50d5641dc72d7e278ca38db2ac746cd8dcc756b245021ea1f9738875b6a831f05185b9217d3f1c287944748 tests-call-name-correctly.patch
7486f98d535380a9e6598b9ac6153564319d5effa25456dc393cf3540ea47ac5b462be79cbd7d8efbd1fc2d2ef240a00873a2e2b138d4b4b0bb1494893de1eac tests-python3.patch"
diff --git a/system/parted/sysmacros.patch b/system/parted/sysmacros.patch
new file mode 100644
index 000000000..b33767c66
--- /dev/null
+++ b/system/parted/sysmacros.patch
@@ -0,0 +1,10 @@
+--- parted-3.2/libparted/arch/linux.c
++++ parted-3.2/libparted/arch/linux.c
+@@ -37,6 +37,7 @@
+ #include <dirent.h>
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+ #include <sys/utsname.h> /* for uname() */
+ #include <scsi/scsi.h>