summaryrefslogtreecommitdiff
path: root/system/perl-module-build-tiny
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-16 17:32:05 -0400
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-17 13:45:34 -0400
commit8afb6ffbf97bc59a6b97d110bf88c9357be5ad83 (patch)
tree7ce023108734fe7872b54addbb4259050d6a0e0c /system/perl-module-build-tiny
parente61f79983d1f626916f5f67e54b9d2ffecf4b2ee (diff)
downloadpackages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.gz
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.bz2
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.xz
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.zip
system/perl-*: modernise
Diffstat (limited to 'system/perl-module-build-tiny')
-rw-r--r--system/perl-module-build-tiny/APKBUILD27
1 files changed, 8 insertions, 19 deletions
diff --git a/system/perl-module-build-tiny/APKBUILD b/system/perl-module-build-tiny/APKBUILD
index 765e79051..d9ddff2a1 100644
--- a/system/perl-module-build-tiny/APKBUILD
+++ b/system/perl-module-build-tiny/APKBUILD
@@ -3,43 +3,32 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-module-build-tiny
_pkgreal=Module-Build-Tiny
+_author=LEONT
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.039
pkgrel=0
pkgdesc="A tiny replacement for Module::Build"
url="https://metacpan.org/release/Module-Build-Tiny"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
-cpandepends="perl-extutils-installpaths perl-extutils-config perl-extutils-helpers perl-test-harness"
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+depends="perl-extutils-installpaths perl-extutils-config perl-extutils-helpers perl-test-harness"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/L/LE/LEONT/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- cd "$builddir"
- if [ -e Build.PL ]; then
- perl Build.PL --installdirs=vendor || return 1
- else
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- fi
-}
-
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ perl Build.PL --installdirs=vendor
./Build
}
check() {
- cd "$builddir"
./Build test
}
package() {
- cd "$builddir"
- ./Build install --destdir="$pkgdir" --create_packlist=0 || return 1
+ ./Build install --destdir="$pkgdir" --create_packlist=0
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}