summaryrefslogtreecommitdiff
path: root/system/perl-test-without-module
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-16 17:32:05 -0400
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-17 13:45:34 -0400
commit8afb6ffbf97bc59a6b97d110bf88c9357be5ad83 (patch)
tree7ce023108734fe7872b54addbb4259050d6a0e0c /system/perl-test-without-module
parente61f79983d1f626916f5f67e54b9d2ffecf4b2ee (diff)
downloadpackages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.gz
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.bz2
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.tar.xz
packages-8afb6ffbf97bc59a6b97d110bf88c9357be5ad83.zip
system/perl-*: modernise
Diffstat (limited to 'system/perl-test-without-module')
-rw-r--r--system/perl-test-without-module/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/system/perl-test-without-module/APKBUILD b/system/perl-test-without-module/APKBUILD
index b39692dc2..5f66fa835 100644
--- a/system/perl-test-without-module/APKBUILD
+++ b/system/perl-test-without-module/APKBUILD
@@ -2,30 +2,31 @@
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-test-without-module
_pkgreal=Test-Without-Module
+_author=CORION
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.20
pkgrel=0
pkgdesc="Test fallback behaviour in absence of Perl modules"
url="https://metacpan.org/release/Test-Without-Module"
arch="noarch"
license="GPL-2.0-only OR Artistic-1.0-Perl"
-makedepends="perl-dev"
+depends="perl"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://search.cpan.org/CPAN/authors/id/C/CO/CORION/Test-Without-Module-$pkgver.tar.gz"
-builddir="$srcdir"/$_pkgreal-$pkgver
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}