summaryrefslogtreecommitdiff
path: root/system/perl-unicode-linebreak
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-10-07 17:00:43 -0500
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-10-07 17:00:43 -0500
commit104061af98bc0a38bad2ea4066e09d7ad38c9137 (patch)
tree21efa8e392bd920bcc28f000b6abb2168d023df7 /system/perl-unicode-linebreak
parent3640bb8d0c71d478fa56172353987262c381729c (diff)
downloadpackages-104061af98bc0a38bad2ea4066e09d7ad38c9137.tar.gz
packages-104061af98bc0a38bad2ea4066e09d7ad38c9137.tar.bz2
packages-104061af98bc0a38bad2ea4066e09d7ad38c9137.tar.xz
packages-104061af98bc0a38bad2ea4066e09d7ad38c9137.zip
system/perl-unicode-linebreak: new out-of-date Unicode support package
Diffstat (limited to 'system/perl-unicode-linebreak')
-rw-r--r--system/perl-unicode-linebreak/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/system/perl-unicode-linebreak/APKBUILD b/system/perl-unicode-linebreak/APKBUILD
new file mode 100644
index 000000000..1f10cb7bb
--- /dev/null
+++ b/system/perl-unicode-linebreak/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=perl-unicode-linebreak
+pkgver=2018.003
+_univer=8.0.0 # update this and unicode.org URLs if sombok is ever updated
+pkgrel=0
+pkgdesc="Perl implementation of the UAX#14 Unicode line-breaking algorithm"
+url="https://metacpan.org/release/Unicode-LineBreak"
+arch="all"
+license="Artistic-1.0-Perl AND GPL-2.0+"
+depends="perl perl-mime-charset"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/N/NE/NEZUMI/Unicode-LineBreak-$pkgver.tar.gz
+ ftp://unicode.org/Public/$_univer/ucd/auxiliary/GraphemeBreakTest.txt
+ ftp://unicode.org/Public/$_univer/ucd/auxiliary/LineBreakTest.txt"
+builddir="$srcdir/Unicode-LineBreak-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ cp "$srcdir"/*Test.txt "$builddir"/test-data
+}
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="37fa931978e1f88667b13ef25eb3b2414a6b055f03fec5925b3605e06026f06af332179e07f35d58f61924f43f305a5bc5ef1d76a61e1d56568abf60c9bf8fc7 Unicode-LineBreak-2018.003.tar.gz
+cc5a4fa7d53c127f749d0c45582f55f391ffdcfa2f2c91c41cb0a4f71e566f1657d4653a6a251c6ae4f769420701df6e0cf184e55413c602cbc5191f9dc99201 GraphemeBreakTest.txt
+d2ffb02fb4d402e6a90937743721692c008b78045e295bd77bcdfcabc99fb1fdbfb0b4679b410bce4487eba115a7ef2e6d6bb03b0a47a7220fa4308eafbac74e LineBreakTest.txt"