summaryrefslogtreecommitdiff
path: root/system/perl/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /system/perl/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'system/perl/APKBUILD')
-rw-r--r--system/perl/APKBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/system/perl/APKBUILD b/system/perl/APKBUILD
index b16bdfa56..7e23f0a82 100644
--- a/system/perl/APKBUILD
+++ b/system/perl/APKBUILD
@@ -1,21 +1,23 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Contributor: Valery Kartel <valery.kartel@gmail.com>
-# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Contributor: Kiyoshi Aman <adelie@aerdan.vulpine.house>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
# Proxy-For: solar
pkgname=perl
pkgver=5.26.3
-pkgrel=0
+pkgrel=1
pkgdesc="Larry Wall's Practical Extraction and Report Language"
url="https://www.perl.org/"
arch="all"
-license="Artistic-1.0-Perl GPL-2.0"
# remove !check when tests pass.
options="!check !fhs"
+license="Artistic-1.0-Perl GPL-2.0"
depends=""
makedepends="bzip2-dev zlib-dev"
subpackages="$pkgname-doc $pkgname-dev"
+# XXX - Remove Getopt::Long when upgrading to 5.32+
source="https://www.cpan.org/src/5.0/perl-$pkgver.tar.gz
+ https://cpan.metacpan.org/authors/id/J/JV/JV/Getopt-Long-2.51.tar.gz
"
# secfixes:
@@ -37,7 +39,6 @@ _archlib=/usr/lib/perl5/core_perl
prepare() {
chmod +w "$builddir"/*.c
default_prepare
- cd "$builddir"
sed -e 's/less -R/less/g' \
-e 's/libswanted="\(.*\) nsl\(.*\)"/libswanted="\1\2"/g' \
-i ./Configure ||
@@ -47,10 +48,11 @@ prepare() {
rm -rf cpan/Compress-Raw-Bzip2/bzip2-src
sed -i '/\(bzip2\|zlib\)-src/d' MANIFEST
+ rm -rf cpan/Getopt-Long && mv "$srcdir"/Getopt-Long-2.51 cpan/Getopt-Long
+ rm cpan/Getopt-Long/Makefile.PL
}
build() {
- cd "$builddir"
BUILD_ZLIB=0
BUILD_BZIP2=0
BZIP2_LIB=/usr/lib
@@ -89,17 +91,16 @@ build() {
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
if [ -n "$(find $pkgdir/usr/local -type f)" ]; then
error "files found under /usr/local"
fi
find "$pkgdir" -name '.*' -delete
+ rm "$pkgdir"/usr/bin/xsubpp
}
dev() {
@@ -110,10 +111,10 @@ dev() {
mv "$pkgdir"/usr/bin/h2xs \
"$pkgdir"/usr/bin/perlivp \
"$pkgdir"/usr/bin/enc2xs \
- "$pkgdir"/usr/bin/xsubpp \
"$subpkgdir"/usr/bin/
default_dev
}
-sha512sums="03914ed51163c998a6afa45610a13cf50124a2c68d291c344b0d52fa15c27fc5d5d4f5dc117516078a03dfd51250097b87c8d5e2b17c7858a4c8c536aecd05af perl-5.26.3.tar.gz"
+sha512sums="03914ed51163c998a6afa45610a13cf50124a2c68d291c344b0d52fa15c27fc5d5d4f5dc117516078a03dfd51250097b87c8d5e2b17c7858a4c8c536aecd05af perl-5.26.3.tar.gz
+e70b2c30f5f85d7bf387381782a22b55f76598e1b4e19102fbf463c4333e91090ad2da49965be6211821d4f7f109aa7e4153348a9142f38fdb1a39299c997c02 Getopt-Long-2.51.tar.gz"