summaryrefslogtreecommitdiff
path: root/system/procps
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-05-04 07:11:41 +0000
committerZach van Rijn <me@zv.io>2022-05-06 12:37:31 -0500
commit5f8662d8bcb6e05ea3a4487433028267d8eff4fb (patch)
treeea2eb6bcaa91c51c6d8c134ba9751bb5a612727c /system/procps
parente657d3ee653db87a38748c3efc8cb6c722f91062 (diff)
downloadpackages-5f8662d8bcb6e05ea3a4487433028267d8eff4fb.tar.gz
packages-5f8662d8bcb6e05ea3a4487433028267d8eff4fb.tar.bz2
packages-5f8662d8bcb6e05ea3a4487433028267d8eff4fb.tar.xz
packages-5f8662d8bcb6e05ea3a4487433028267d8eff4fb.zip
system/procps: bump { 3.3.16 --> 3.3.17 }.
Diffstat (limited to 'system/procps')
-rw-r--r--system/procps/APKBUILD8
-rw-r--r--system/procps/add-langinfo-header.patch11
-rw-r--r--system/procps/use-utmpx.patch104
3 files changed, 21 insertions, 102 deletions
diff --git a/system/procps/APKBUILD b/system/procps/APKBUILD
index 32fe9fdd0..11ccc7172 100644
--- a/system/procps/APKBUILD
+++ b/system/procps/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=procps
-pkgver=3.3.16
+pkgver=3.3.17
pkgrel=0
pkgdesc="Utilities for monitoring your system and processes on your system"
url="https://gitlab.com/procps-ng/procps"
@@ -13,6 +13,7 @@ makedepends_host="ncurses-dev utmps-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang libproc"
source="https://gitlab.com/procps-ng/procps/-/archive/v$pkgver/procps-v$pkgver.tar.bz2
use-utmpx.patch
+ add-langinfo-header.patch
"
builddir="$srcdir/$pkgname-v$pkgver"
@@ -69,5 +70,6 @@ libproc() {
mv "$pkgdir"/lib "$subpkgdir"/
}
-sha512sums="633c6fe90e753f5c489de7f8728ca5fe4647663a3e58ab66f77229a5991f6e7a7d174ddec2d2dfcd3b65146dd04ac6ea9c98697457edf785cb516ec3ec120f0b procps-v3.3.16.tar.bz2
-6683b94f64848721ebce8254461fbd70a3efd048bf9579c5bbe298bd1ec00594c05640327f0e03475e583607f1f7405139b93fc9f06592d5593174cbf6d4119f use-utmpx.patch"
+sha512sums="7f4ad6a76b042a2478fa866ea63d6826129b08b734c6341155134fcc73c0cf0df429c369dbd5aa65b28ebeeb1ab6ee8df4f2dab2083951bad539bce916e14b64 procps-v3.3.17.tar.bz2
+77cfd89cf75e937806dd068a83da3ad548000b941401fce49a482988dc8db82438ade2a939cf6fe795a59059275ffc4a61520b169da60f53ecef408a24042bcf use-utmpx.patch
+f1085cec2fab869b94d2a4b45baf68d6316e8f2ac729cd23341ef27c871df91f83f8953a777a0e858b244d8faf5171f9c640b9e7616c9a5d9c816fa044b92a78 add-langinfo-header.patch"
diff --git a/system/procps/add-langinfo-header.patch b/system/procps/add-langinfo-header.patch
new file mode 100644
index 000000000..8498271e8
--- /dev/null
+++ b/system/procps/add-langinfo-header.patch
@@ -0,0 +1,11 @@
+diff -ur a/proc/escape.c b/proc/escape.c
+--- a/proc/escape.c 2022-05-04 06:50:01.750000000 +0000
++++ b/proc/escape.c 2022-05-04 06:50:29.050000000 +0000
+@@ -20,6 +20,7 @@
+ #include <stdio.h>
+ #include <sys/types.h>
+ #include <string.h>
++#include <langinfo.h>
+ #include <limits.h>
+ #include "procps.h"
+ #include "escape.h"
diff --git a/system/procps/use-utmpx.patch b/system/procps/use-utmpx.patch
index 83047cf22..608ea6182 100644
--- a/system/procps/use-utmpx.patch
+++ b/system/procps/use-utmpx.patch
@@ -1,20 +1,6 @@
-diff --git a/configure.ac b/configure.ac
-index bc84a0d..da2916e 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -44,7 +44,7 @@ AC_PROG_MAKE_SET
-
- # Checks for header files.
- AC_HEADER_MAJOR
--AC_CHECK_HEADERS([arpa/inet.h fcntl.h float.h langinfo.h libintl.h limits.h locale.h netinet/in.h stdint.h stdio_ext.h stdlib.h string.h sys/file.h sys/ioctl.h sys/param.h sys/time.h termios.h unistd.h utmp.h values.h wchar.h wctype.h])
-+AC_CHECK_HEADERS([arpa/inet.h fcntl.h float.h langinfo.h libintl.h limits.h locale.h netinet/in.h stdint.h stdio_ext.h stdlib.h string.h sys/file.h sys/ioctl.h sys/param.h sys/time.h termios.h unistd.h utmp.h utmpx.h values.h wchar.h wctype.h])
-
- # Checks for typedefs, structures, and compiler characteristics.
- AC_CHECK_HEADER_STDBOOL
-diff --git a/proc/whattime.c b/proc/whattime.c
-index c223cad..d55fd22 100644
---- a/proc/whattime.c
-+++ b/proc/whattime.c
+diff -ur a/proc/whattime.c b/proc/whattime.c
+--- a/proc/whattime.c 2022-05-04 07:08:11.390000000 +0000
++++ b/proc/whattime.c 2022-05-04 07:08:42.860000000 +0000
@@ -33,7 +33,7 @@
#include <fcntl.h>
#include <unistd.h>
@@ -24,7 +10,7 @@ index c223cad..d55fd22 100644
#include <sys/ioctl.h>
#include "whattime.h"
#include "sysinfo.h"
-@@ -42,7 +42,7 @@ static char buf[256];
+@@ -42,7 +43,7 @@
static double av[3];
char *sprint_uptime(int human_readable) {
@@ -33,7 +19,7 @@ index c223cad..d55fd22 100644
int upminutes, uphours, updays, upweeks, upyears, updecades;
int pos;
int comma;
-@@ -98,13 +98,13 @@ char *sprint_uptime(int human_readable) {
+@@ -98,13 +99,13 @@
/* count the number of users */
numuser = 0;
@@ -50,83 +36,3 @@ index c223cad..d55fd22 100644
pos += sprintf(buf + pos, "%2d user%s, ", numuser, numuser == 1 ? "" : "s");
-diff --git a/w.c b/w.c
-index 35710a3..6caa8a6 100644
---- a/w.c
-+++ b/w.c
-@@ -23,6 +23,7 @@
- * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
- */
-
-+#include "config.h"
- #include "c.h"
- #include "fileutils.h"
- #include "nls.h"
-@@ -54,14 +55,22 @@
- #include <termios.h>
- #include <time.h>
- #include <unistd.h>
--#include <utmp.h>
-+#ifdef HAVE_UTMPX_H
-+# include <utmpx.h>
-+#else
-+# include <utmp.h>
-+#endif
- #include <arpa/inet.h>
-
- static int ignoreuser = 0; /* for '-u' */
- static int oldstyle = 0; /* for '-o' */
- static proc_t **procs; /* our snapshot of the process table */
-
-+#ifdef HAVE_UTMPX_H
-+typedef struct utmpx utmp_t;
-+#else
- typedef struct utmp utmp_t;
-+#endif
-
- #ifdef W_SHOWFROM
- # define FROM_STRING "on"
-@@ -604,11 +613,19 @@ int main(int argc, char **argv)
- printf(_(" IDLE WHAT\n"));
- }
-
-+#ifdef HAVE_UTMPX_H
-+ setutxent();
-+#else
- utmpname(UTMP_FILE);
- setutent();
-+#endif
- if (user) {
- for (;;) {
-+#ifdef HAVE_UTMPX_H
-+ u = getutxent();
-+#else
- u = getutent();
-+#endif
- if (unlikely(!u))
- break;
- if (u->ut_type != USER_PROCESS)
-@@ -619,7 +636,11 @@ int main(int argc, char **argv)
- }
- } else {
- for (;;) {
-+#ifdef HAVE_UTMPX_H
-+ u = getutxent();
-+#else
- u = getutent();
-+#endif
- if (unlikely(!u))
- break;
- if (u->ut_type != USER_PROCESS)
-@@ -629,7 +650,11 @@ int main(int argc, char **argv)
- fromlen, ip_addresses);
- }
- }
-+#ifdef HAVE_UTMPX_H
-+ endutxent();
-+#else
- endutent();
-+#endif
-
- return EXIT_SUCCESS;
- }