summaryrefslogtreecommitdiff
path: root/system/util-linux/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-06-04 01:26:59 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-06-04 01:26:59 +0000
commite7ad0470268e396c3fa475235f877bd20669ab0f (patch)
tree0951a13368f3e8dca17d027bf81a8c5bc31cfecc /system/util-linux/APKBUILD
parent5641b34207407e26e9265721f068efed6b118a99 (diff)
downloadpackages-e7ad0470268e396c3fa475235f877bd20669ab0f.tar.gz
packages-e7ad0470268e396c3fa475235f877bd20669ab0f.tar.bz2
packages-e7ad0470268e396c3fa475235f877bd20669ab0f.tar.xz
packages-e7ad0470268e396c3fa475235f877bd20669ab0f.zip
system/util-linux: fix cycle with libfdisk
libfdisk deps on util-linux, and util-linux deps on libfdisk. Just don't split it any more.
Diffstat (limited to 'system/util-linux/APKBUILD')
-rw-r--r--system/util-linux/APKBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/system/util-linux/APKBUILD b/system/util-linux/APKBUILD
index f12fb48dc..fb2a5f734 100644
--- a/system/util-linux/APKBUILD
+++ b/system/util-linux/APKBUILD
@@ -9,7 +9,7 @@ case $pkgver in
*.*) _v=$pkgver;;
esac
-pkgrel=0
+pkgrel=1
pkgdesc="Official Linux system management utilities"
url="https://git.kernel.org/pub/scm/utils/util-linux/util-linux.git"
arch="all"
@@ -19,13 +19,15 @@ depends=""
makedepends_build="autoconf automake libtool"
makedepends_host="zlib-dev ncurses-dev linux-headers libcap-ng-dev utmps-dev"
subpackages="$pkgname-doc $pkgname-dev $pkgname-bash-completion:bashcomp:noarch
- libuuid libfdisk $pkgname-lang"
+ libuuid $pkgname-lang"
makedepends="$makedepends_build $makedepends_host"
replaces="e2fsprogs util-linux-ng sfdisk cfdisk findmnt mcookie blkid setpriv
- libblkid libsmartcols libmount"
-provides="sfdisk=$pkgver-$pkgrel cfdisk=$pkgver-$pkgrel findmnt=$pkgver-$pkgrel
- mcookie=$pkgver-$pkgrel blkid=$pkgver-$pkgrel libblkid=$pkgver-$pkgrel
- libmount=$pkgver-$pkgrel libsmartcols=$pkgver-$pkgrel"
+ libblkid libsmartcols libmount libfdisk"
+provides="sfdisk=$pkgver-r$pkgrel cfdisk=$pkgver-r$pkgrel
+ findmnt=$pkgver-r$pkgrel mcookie=$pkgver-r$pkgrel
+ blkid=$pkgver-r$pkgrel libblkid=$pkgver-r$pkgrel
+ libmount=$pkgver-r$pkgrel libsmartcols=$pkgver-r$pkgrel
+ libfdisk=$pkgver-r$pkgrel"
source="https://www.kernel.org/pub/linux/utils/$pkgname/v${_v}/$pkgname-$pkgver.tar.xz
ttydefaults.h
"
@@ -92,13 +94,5 @@ libmount() {
mv "$pkgdir"/lib/libmount.so.* "$subpkgdir"/lib/
}
-libfdisk() {
- pkgdesc="Partitioning library for fdisk-like programs"
- license="LGPL.2.1+"
- depends=""
- mkdir -p "$subpkgdir"/lib
- mv "$pkgdir"/lib/libfdisk.so.* "$subpkgdir"/lib/
-}
-
sha512sums="ac88790a0272366b384b54df19cb28318014d98819d5d96aa05528ff17ab57a8c66d012a2f1b59caca4c5d4ea669e8c041e1123517c1f1c2d9960ef701aaf749 util-linux-2.33.2.tar.xz
876bb9041eca1b2cca1e9aac898f282db576f7860aba690a95c0ac629d7c5b2cdeccba504dda87ff55c2a10b67165985ce16ca41a0694a267507e1e0cafd46d9 ttydefaults.h"