summaryrefslogtreecommitdiff
path: root/system/zip/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /system/zip/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'system/zip/APKBUILD')
-rw-r--r--system/zip/APKBUILD3
1 files changed, 0 insertions, 3 deletions
diff --git a/system/zip/APKBUILD b/system/zip/APKBUILD
index ed060ef03..457dbac28 100644
--- a/system/zip/APKBUILD
+++ b/system/zip/APKBUILD
@@ -15,16 +15,13 @@ source="https://sourceforge.net/projects/infozip/files/Zip%203.x%20%28latest%29/
10-zip-3.0-build.patch
20-zip-3.0-exec-stack.patch
30-zip-3.0-pic.patch"
-
builddir="$srcdir"/${pkgname}30
build() {
- cd "$builddir"
make -f unix/Makefile LOCAL_ZIP="${CFLAGS} ${CPPFLAGS}" prefix=/usr generic
}
package() {
- cd "$builddir"
make -f unix/Makefile prefix=${pkgdir}/usr MANDIR=${pkgdir}/usr/share/man install
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}