summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-06-28 09:54:44 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-06-28 09:54:44 +0000
commit05af7118208240aad473c9c94d84642219325b21 (patch)
treefe5954c6b9585ecec14f93ff4cdc602b926f776f /system
parent07e70fdeeb23400185562a7d65fdc699bee40c4b (diff)
parent849c6d27691fb7901ad3e364ffa4cc69f6cb26e3 (diff)
downloadpackages-05af7118208240aad473c9c94d84642219325b21.tar.gz
packages-05af7118208240aad473c9c94d84642219325b21.tar.bz2
packages-05af7118208240aad473c9c94d84642219325b21.tar.xz
packages-05af7118208240aad473c9c94d84642219325b21.zip
Merge branch 'bump.djt.20190625' into 'master'
djt's June 2019 Package Bumps This MR bumps most of the outdated packages that I maintain to their latest versions. See merge request !256
Diffstat (limited to 'system')
-rw-r--r--system/docbook-xsl/APKBUILD32
-rw-r--r--system/iproute2/0001-f_flower-fix-build-with-musl-libc.patch28
-rw-r--r--system/iproute2/APKBUILD13
-rw-r--r--system/iproute2/devlink-sysinfo.patch43
-rw-r--r--system/iproute2/fix-uapi-garbage.patch22
-rw-r--r--system/lvm2/APKBUILD4
-rw-r--r--system/lz4/APKBUILD4
7 files changed, 82 insertions, 64 deletions
diff --git a/system/docbook-xsl/APKBUILD b/system/docbook-xsl/APKBUILD
index 0482a76ef..ebfbf4dee 100644
--- a/system/docbook-xsl/APKBUILD
+++ b/system/docbook-xsl/APKBUILD
@@ -2,23 +2,25 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=docbook-xsl
pkgver=1.79.1
-pkgrel=2
+pkgrel=3
pkgdesc="XML stylesheets for Docbook-xml transformations."
url="http://docbook.sourceforge.net/"
arch="noarch"
options="!check" # Just XML files
license="MIT"
depends="libxml2-utils libxslt docbook-xml"
+subpackages="$pkgname-ns"
makedepends=""
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
source="http://downloads.sourceforge.net/sourceforge/docbook/$pkgname-$pkgver.tar.bz2
+ https://downloads.sourceforge.net/project/docbook/docbook-xsl-ns/$pkgver/$pkgname-ns-$pkgver.tar.bz2
765567_non-recursive_string_subst.patch
"
package() {
cd "$builddir"
local _dest dir f
- _dest="$pkgdir"/usr/share/xml/docbook/xsl-stylesheets-$pkgver
+ _dest="$pkgdir"/usr/share/xml/docbook/xsl-stylesheets
install -dm755 "$_dest"
install -m644 VERSION VERSION.xsl "$_dest"/
@@ -40,5 +42,31 @@ package() {
"$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
+ns() {
+ cd "$srcdir/${pkgname}-ns-${pkgver}"
+ local _dest dir f
+ _dest="$subpkgdir"/usr/share/xml/docbook/xsl-stylesheets-ns
+
+ install -dm755 "$_dest"
+ install -m644 VERSION VERSION.xsl "$_dest"/
+
+ for dir in assembly common eclipse epub epub3 fo highlighting html \
+ htmlhelp javahelp lib manpages params profiling roundtrip \
+ template website xhtml xhtml-1_1 xhtml5; do
+
+ install -dm755 $_dest/$dir
+ for f in $dir/*.xml $dir/*.xsl $dir/*.dtd $dir/*.ent; do
+ [ -e "$f" ] || continue
+ install -m644 $f $_dest/$dir
+ done
+ done
+
+ install -dm755 "$subpkgdir"/etc/xml
+
+ install -m644 -D COPYING \
+ "$subpkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
sha512sums="83325cbaf1545da6b9b8b77f5f0e6fdece26e3c455164b300a1aa3d19e3bd29ae71fd563553a714a5394968d1a65684c6c7987c77524469358d18b8c227025c7 docbook-xsl-1.79.1.tar.bz2
+23fd06870bd5afe4efcd08c8ad679821c202a62442b50657c093cbe9cd71b585a3c56a5534a0d41119f58bf98b1f9014a53ff2e48ab59075ec1827e7363980e9 docbook-xsl-ns-1.79.1.tar.bz2
6a26838078a3ce28273dddfa1af6a378cffc28b6d1ba48a4cfc839addd7bf58ce217d6584b735f9c75381954744ab2386c75fa3c593858b6e27882be55c00d04 765567_non-recursive_string_subst.patch"
diff --git a/system/iproute2/0001-f_flower-fix-build-with-musl-libc.patch b/system/iproute2/0001-f_flower-fix-build-with-musl-libc.patch
deleted file mode 100644
index 8a51affe5..000000000
--- a/system/iproute2/0001-f_flower-fix-build-with-musl-libc.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 28747146622a49c3e7b5c5b36dc02c6a64124770 Mon Sep 17 00:00:00 2001
-From: Hans Dedecker <dedeckeh@gmail.com>
-Date: Wed, 23 Jan 2019 22:02:31 +0100
-Subject: [PATCH] f_flower: fix build with musl libc
-
-XATTR_SIZE_MAX requires the usage of linux/limits.h; let's include it
-
-Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
-Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
----
- tc/f_flower.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/tc/f_flower.c b/tc/f_flower.c
-index c5636667..9659e894 100644
---- a/tc/f_flower.c
-+++ b/tc/f_flower.c
-@@ -14,6 +14,7 @@
- #include <unistd.h>
- #include <string.h>
- #include <net/if.h>
-+#include <linux/limits.h>
- #include <linux/if_arp.h>
- #include <linux/if_ether.h>
- #include <linux/ip.h>
---
-2.19.2
-
diff --git a/system/iproute2/APKBUILD b/system/iproute2/APKBUILD
index 500a49f18..4b4b6060c 100644
--- a/system/iproute2/APKBUILD
+++ b/system/iproute2/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=iproute2
-pkgver=4.20.0
+pkgver=5.1.0
pkgrel=0
pkgdesc="IP configuration, routing, and traffic control utilities"
url="https://wiki.linuxfoundation.org/networking/iproute2"
@@ -10,13 +10,11 @@ arch="all"
options="!check"
license="GPL-2.0-only"
depends=""
-makedepends="bison flex bash libelf-dev libmnl-dev libcap-dev"
+makedepends="bison flex bash libelf-dev libmnl-dev libcap-dev bsd-compat-headers"
install="$pkgname.post-install"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
source="https://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz
- fix-uapi-garbage.patch
- 0001-f_flower-fix-build-with-musl-libc.patch
- "
+ devlink-sysinfo.patch"
prepare() {
default_prepare
@@ -54,6 +52,5 @@ bashcomp() {
rmdir -p "$pkgdir"/usr/share 2>/dev/null || true
}
-sha512sums="ed29638c864062e199152c7b3b24b6495987ca6f79cc9ab1b529dab37a8a840fa2b5858d5db2b94eeefa1c0d72ff666a790107e27d11a597b189bfb7a01a4b8b iproute2-4.20.0.tar.xz
-d9b40539f4ac074f20b0bb10381de9c3b64aadf612f0d599814cdb632fe97c76c9b4730406b08a6e53739670ca51ea0f699862156247cf20c3b7f4c78394fa46 fix-uapi-garbage.patch
-b6b5dc65fb4ffff06978c160446bcc79f4f242c94d0ba44890f3b01d86640f56e7cc32efbc0b2bbfce1ae5fd40252ba9ddbb59ff91e54a4de1d4274d48260b2c 0001-f_flower-fix-build-with-musl-libc.patch"
+sha512sums="5c8319b040bd0ba98cf1225b2a77efafc662741344c53877ee38cf108ca01906b03328e4f9b00b7557e301c6e64bca4e42e92af477b4d657bcbff5120c0c4e87 iproute2-5.1.0.tar.xz
+3585c70d110749e0bdba7f1bbdc32c7d635147026fbb9662f63dfcca2405e8a45cc990cb6ad38b6405cde23a1535a59ff854387ae1649b4241597ec71f445e20 devlink-sysinfo.patch"
diff --git a/system/iproute2/devlink-sysinfo.patch b/system/iproute2/devlink-sysinfo.patch
new file mode 100644
index 000000000..316fcefae
--- /dev/null
+++ b/system/iproute2/devlink-sysinfo.patch
@@ -0,0 +1,43 @@
+Since commit 2f1242efe9d ("devlink: Add devlink health show command") we
+use the sys/sysinfo.h header for the sysinfo(2) system call. But since
+iproute2 carries a local version of the kernel struct sysinfo, this
+causes a collision with libc that do not rely on kernel defined sysinfo
+like musl libc:
+
+In file included from devlink.c:25:0:
+.../sysroot/usr/include/sys/sysinfo.h:10:8: error: redefinition of 'struct sysinfo'
+ struct sysinfo {
+ ^~~~~~~
+In file included from ../include/uapi/linux/kernel.h:5:0,
+ from ../include/uapi/linux/netlink.h:5,
+ from ../include/uapi/linux/genetlink.h:6,
+ from devlink.c:21:
+../include/uapi/linux/sysinfo.h:8:8: note: originally defined here
+ struct sysinfo {
+ ^~~~~~~
+
+Rely on the kernel header alone to avoid kernel and userspace headers
+collision of definitions.
+
+Cc: Aya Levin <ayal@xxxxxxxxxxxx>
+Cc: Moshe Shemesh <moshe@xxxxxxxxxxxx>
+Signed-off-by: Baruch Siach <baruch@xxxxxxxxxx>
+---
+ devlink/devlink.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/devlink/devlink.c b/devlink/devlink.c
+index 436935f88bda..d7a6ce94f0e6 100644
+--- a/devlink/devlink.c
++++ b/devlink/devlink.c
+@@ -22,7 +22,7 @@
+ #include <linux/devlink.h>
+ #include <libmnl/libmnl.h>
+ #include <netinet/ether.h>
+-#include <sys/sysinfo.h>
++#include <linux/sysinfo.h>
+ #include <sys/queue.h>
+
+ #include "SNAPSHOT.h"
+--
+2.20.1 \ No newline at end of file
diff --git a/system/iproute2/fix-uapi-garbage.patch b/system/iproute2/fix-uapi-garbage.patch
deleted file mode 100644
index 9f899ebb0..000000000
--- a/system/iproute2/fix-uapi-garbage.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- iproute2-4.17.0/rdma/rdma.h 2018-06-08 12:11:50.000000000 -0500
-+++ iproute2-4.17.0/rdma/rdma.h 2018-06-25 23:26:35.811455508 -0500
-@@ -16,15 +16,16 @@
- #include <errno.h>
- #include <getopt.h>
- #include <libmnl/libmnl.h>
--#include <rdma/rdma_netlink.h>
--#include <rdma/rdma_user_cm.h>
- #include <time.h>
--#include <net/if_arp.h>
-
- #include "list.h"
- #include "utils.h"
- #include "json_writer.h"
-
-+#include <rdma/rdma_netlink.h>
-+#include <rdma/rdma_user_cm.h>
-+#include <net/if_arp.h>
-+
- #define pr_err(args...) fprintf(stderr, ##args)
- #define pr_out(args...) fprintf(stdout, ##args)
-
diff --git a/system/lvm2/APKBUILD b/system/lvm2/APKBUILD
index efb73d48f..8287d3813 100644
--- a/system/lvm2/APKBUILD
+++ b/system/lvm2/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=lvm2
-pkgver=2.03.02
+pkgver=2.03.05
pkgrel=0
pkgdesc="Logical Volume Manager 2 utilities"
url="https://sourceware.org/lvm2/"
@@ -105,7 +105,7 @@ dm_event_libs() {
mv "$pkgdir"/lib/libdevmapper-event.so.* "$subpkgdir"/lib/
}
-sha512sums="b8ccd96a98bee36272492ed056aa0bd65e074e476f29d6e5562ff4604a18326cbf40a7948f2c37d8d4758a1403c3c98106f2698e1e2ba5e014e4cb91aeb3cf90 LVM2.2.03.02.tgz
+sha512sums="3b00f53771e99faa6459ae73353bff06ae37c64bd2659586ec25d0bb43bc3ff8ba5f713c68617fd7662a5f6cb65bca1ad0aea554819048d79c1cce20bf67c50a LVM2.2.03.05.tgz
6ea4efad03f8632f2883f33f9d9f8ca295f7d8d2aa1bfbfa7738e7d711727a511758848dde5776b222bd74e6fb60bed8b56a3cd2f74ca448b8d86f50470a42b9 fix-stdio-usage.patch
9272ec8c5184ef5dc776ead8f74132e072b7563b5119a3a38b712f00d92a1e3878c9b3a54eb2b01dcba038110c686b39d4c17ecd0eb258537e9217d7ed03c408 mallinfo.patch
33004594a5cce7af1e493a2a66ce8ad2f864dde3b2ec0960d0fda9df9b7bcf65d9455f9eccf7860f48726c48f14111b843b0a0c9bd395ef2952b41aaab8092b2 library_dir-default-config.patch
diff --git a/system/lz4/APKBUILD b/system/lz4/APKBUILD
index b7c8a56b7..281c3248c 100644
--- a/system/lz4/APKBUILD
+++ b/system/lz4/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=lz4
-pkgver=1.8.3
+pkgver=1.9.1
pkgrel=0
pkgdesc="LZ4: Extremely Fast Compression algorithm"
url="https://github.com/lz4/lz4"
@@ -27,4 +27,4 @@ package() {
make PREFIX="/usr" DESTDIR="$pkgdir" install
}
-sha512sums="5d284f75a0c4ad11ebc4abb4394d98c863436da0718d62f648ef2e2cda8e5adf47617a4b43594375f7b0b673541a9ccfaf73880a55fd240986594558214dbf9f lz4-1.8.3.tar.gz"
+sha512sums="536cdeb6dd73b4769cf9501ad312b004ab01699758534b47ca2eddbc815fd374a3caba40cde36f73a7a70e134065836b733e2b0c023c31740b877ef9317ccf3e lz4-1.9.1.tar.gz"