summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorLaurent Bercot <ska-adelie@skarnet.org>2024-10-10 02:59:48 +0000
committerLaurent Bercot <ska-adelie@skarnet.org>2024-10-10 02:59:48 +0000
commit3221c0f862fe010704281ec3a4612c588b0f7d25 (patch)
treebb8c62d98877d3b81893690f5adbf61b4fe8cb5f /system
parent3e08e2bf85000b9eb3970498a20034f2568d6782 (diff)
downloadpackages-3221c0f862fe010704281ec3a4612c588b0f7d25.tar.gz
packages-3221c0f862fe010704281ec3a4612c588b0f7d25.tar.bz2
packages-3221c0f862fe010704281ec3a4612c588b0f7d25.tar.xz
packages-3221c0f862fe010704281ec3a4612c588b0f7d25.zip
system/utmps: upgrade to 0.1.2.3
Also add a .pc file
Diffstat (limited to 'system')
-rw-r--r--system/utmps/APKBUILD20
-rw-r--r--system/utmps/utmps.pc.in6
2 files changed, 16 insertions, 10 deletions
diff --git a/system/utmps/APKBUILD b/system/utmps/APKBUILD
index 7ae3849ed..b8dda2050 100644
--- a/system/utmps/APKBUILD
+++ b/system/utmps/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: Laurent Bercot <ska-adelie@skarnet.org>
# Maintainer: Laurent Bercot <ska-adelie@skarnet.org>
pkgname=utmps
-pkgver=0.1.2.2
-pkgrel=2
+pkgver=0.1.2.3
+pkgrel=0
pkgdesc="A secure utmp/wtmp implementation"
url="https://skarnet.org/software/utmps/"
arch="all"
options="!check" # No test suite
license="ISC"
depends="execline s6"
-_skalibs_version=2.14
+_skalibs_version=2.14.3
depends_dev="skalibs-dev>=$_skalibs_version"
makedepends="skalibs-dev>=$_skalibs_version"
subpackages="$pkgname-dev $pkgname-libs $pkgname-doc $pkgname-openrc"
@@ -18,17 +18,14 @@ source="https://skarnet.org/software/$pkgname/$pkgname-$pkgver.tar.gz
utmpd.run
wtmpd.run
btmpd.run
- utmps.initd"
+ utmps.initd
+ utmps.pc.in"
build() {
./configure \
--enable-shared \
- --enable-static \
- --enable-allstatic \
--enable-static-libc \
- --libdir=/usr/lib \
--libexecdir="/lib/$pkgname" \
- --with-dynlib=/lib \
--enable-libc-includes
make
}
@@ -39,6 +36,8 @@ package() {
mkdir -p -m 0755 "$runimage/utmps" "$pkgdir/usr/share/doc"
chown utmp:utmp "$runimage/utmps"
install -D -m 0755 "$srcdir/utmps.initd" "$pkgdir/etc/init.d/utmps"
+ sed -e "s/@@VERSION@@/$pkgver/g; s/@@SKALIBS_VERSION@@/${_skalibs_version}/g;" "$srcdir/$pkgname.pc.in" > "$srcdir/$pkgname.pc"
+ install -D -m 0644 "$srcdir/$pkgname.pc" "$pkgdir/usr/lib/pkgconfig/$pkgname.pc"
cp -a "$builddir/doc" "$pkgdir/usr/share/doc/$pkgname"
}
@@ -63,8 +62,9 @@ openrc() {
ln -s ../../init.d/utmps "$rldir/utmps"
}
-sha512sums="57a73658ecb947af9dfad7a5e2931660ad1b8fa61d36c803c373e8aba13e9afa8398c1522765f5ea2b5df87d942cea17062faf30f589afa6acc744ff3ae4a409 utmps-0.1.2.2.tar.gz
+sha512sums="41822b5ef582c86cd2439f13c88871bef2d496e6c7ae5493d9e2be70c7cf2f25656dedf045b4dbe925b1c6b3bfbadc7430a898ccc56951f096e768990a9735df utmps-0.1.2.3.tar.gz
0ec30284c64c6ea9f25142c5f4a643bd48b137fe85781b650104f5137ffa4dfc35ca7be3e41e3acd3403ebe1d8c5378073afa4e2f3607d3d794fcd9f98ed51c4 utmpd.run
9e875a5cd37be531320a8e582afed2c980dd0a1bdfc2f6f3d826d5e5389fc6ab93f973ed1506edb23f4c73cf24a2357aefe856148eaacff86c2aafe376c575e2 wtmpd.run
503bdbb3d244243934b9b4e3deea0bf92a95f88417c822ad9cf6202584d4724d5e182a0d88d7f09069e435a8a97230b85d2b264736c85c893da193fd5ec34c71 btmpd.run
-89fb24ab5759b3a1162044895efbe01c7a17d505a29df0cd7141654783b7ada8e934a1ce5981218af41812cfb517263bbd608948102af40b7a41a843b7aaf6ca utmps.initd"
+89fb24ab5759b3a1162044895efbe01c7a17d505a29df0cd7141654783b7ada8e934a1ce5981218af41812cfb517263bbd608948102af40b7a41a843b7aaf6ca utmps.initd
+d5ac39af2e688b5a118302ff31f15a0ea708eff4a94e2f6631c37f77ae528d64034ada1685f302af5b09816b617aae13b3513721883c8d9fee33fe729377f435 utmps.pc.in"
diff --git a/system/utmps/utmps.pc.in b/system/utmps/utmps.pc.in
new file mode 100644
index 000000000..ef581ec6f
--- /dev/null
+++ b/system/utmps/utmps.pc.in
@@ -0,0 +1,6 @@
+Name: utmps
+Description: A secure implementation of the utmp mechanism.
+URL: https://skarnet.org/software/utmps/
+Version: @@VERSION@@
+Requires.private: skalibs >= @@SKALIBS_VERSION@@
+Libs: -lutmps