summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-12-04 17:31:24 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-12-04 17:31:24 -0600
commit730f0a84f08e1b0dad8cc34e9d260802b7777fc0 (patch)
tree73f9449bdeb89efef394b89c9c0a9ea085d47421 /system
parentbfc21ddbb093bcb73f7b2c6d1e3cc9767e08ea62 (diff)
downloadpackages-730f0a84f08e1b0dad8cc34e9d260802b7777fc0.tar.gz
packages-730f0a84f08e1b0dad8cc34e9d260802b7777fc0.tar.bz2
packages-730f0a84f08e1b0dad8cc34e9d260802b7777fc0.tar.xz
packages-730f0a84f08e1b0dad8cc34e9d260802b7777fc0.zip
user/chrpath: Move to system/
Needed by LLVM bootstrap compilers. Acked-by: Zach van Rijn <me@zv.io>
Diffstat (limited to 'system')
-rw-r--r--system/chrpath/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/system/chrpath/APKBUILD b/system/chrpath/APKBUILD
new file mode 100644
index 000000000..7bdb44c39
--- /dev/null
+++ b/system/chrpath/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer:
+pkgname=chrpath
+pkgver=0.16
+pkgrel=2
+pkgdesc="Modify rpath of compiled programs"
+url="https://github.com/jwilk-mirrors/chrpath"
+arch="all"
+license="GPL-2.0-only"
+depends=""
+makedepends=""
+subpackages="$pkgname-doc"
+source="https://alioth-archive.debian.org/releases/chrpath/chrpath/0.16/chrpath-0.16.tar.gz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" docdir=/usr/share/doc/$pkgname-$pkgver \
+ install
+}
+
+sha512sums="aa04d490f78bff20a56fe20539cec10218c0772a668909eda8324ca825f51e8ef92001e95d9c316e79a145a043c9c327ec94d1a82e104ab408ca1021832745aa chrpath-0.16.tar.gz"