summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 08:25:47 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-14 08:25:47 +0000
commitec1d2fc6b5639d227670e0a689135fd5ab6bffbb (patch)
tree3a2e963471465f01a1e49a246c213797d3ffff93 /system
parent3eab93d8cb03fd0395c9b495617526e344573219 (diff)
downloadpackages-ec1d2fc6b5639d227670e0a689135fd5ab6bffbb.tar.gz
packages-ec1d2fc6b5639d227670e0a689135fd5ab6bffbb.tar.bz2
packages-ec1d2fc6b5639d227670e0a689135fd5ab6bffbb.tar.xz
packages-ec1d2fc6b5639d227670e0a689135fd5ab6bffbb.zip
system/git: Bump to 2.25.0
Diffstat (limited to 'system')
-rw-r--r--system/git/APKBUILD8
-rw-r--r--system/git/dont-test-other-encodings.patch135
2 files changed, 4 insertions, 139 deletions
diff --git a/system/git/APKBUILD b/system/git/APKBUILD
index 07adcfdaa..0440b0f0b 100644
--- a/system/git/APKBUILD
+++ b/system/git/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=git
-pkgver=2.24.1
+pkgver=2.25.0
pkgrel=0
pkgdesc="Distributed version control system"
url="https://www.git-scm.com/"
@@ -22,6 +22,7 @@ subpackages="$pkgname-doc
$pkgname-gitweb
$pkgname-subtree::noarch
$pkgname-subtree-doc:subtree_doc:noarch
+ $pkgname-lang
"
replaces="git-perl perl-git"
source="https://www.kernel.org/pub/software/scm/git/git-$pkgver.tar.xz
@@ -50,7 +51,6 @@ _gitcoredir=/usr/libexec/git-core
prepare() {
default_prepare
cat >> config.mak <<-EOF
- NO_GETTEXT=YesPlease
NO_SVN_TESTS=YesPlease
NO_REGEX=YesPlease
USE_ASCIIDOCTOR=1
@@ -173,7 +173,7 @@ subtree_doc() {
gzip -9 "$subpkgdir"/usr/share/man/man1/git-subtree.1
}
-sha512sums="010c13d4023c142876d0e075a394b74bef422944d8ca602325d0b2b47bf28b1d534283c7f295751113c83fdfcc0c91f97090e8f906560d44b04a94607fd8fcf7 git-2.24.1.tar.xz
-315e4666c425b31a7f7a447e777cbf2a1050feac9b4d4b8a61c05248024e790d4d18f3336faf2a2c68584e05e8194c22a09e1caba1352cfec194e0bc01277a6c dont-test-other-encodings.patch
+sha512sums="8bbada0451fe0a3314e1b9a43a74135115449aa41f5b3e7f960279e4a7fe6069c36e78825fc4b60d06806e3a6fa8158f327cb8a3801686ac22a35e3704244191 git-2.25.0.tar.xz
+0a0935d876024d96156df3aeec06b47fd9e370484d4552786c450cb500ae671a631e64c30994ec39f43a2f313f75d68909688ea92b47327d1af65e365dc77480 dont-test-other-encodings.patch
89528cdd14c51fd568aa61cf6c5eae08ea0844e59f9af9292da5fc6c268261f4166017d002d494400945e248df6b844e2f9f9cd2d9345d516983f5a110e4c42a git-daemon.initd
fbf1f425206a76e2a8f82342537ed939ff7e623d644c086ca2ced5f69b36734695f9f80ebda1728f75a94d6cd2fcb71bf845b64239368caab418e4d368c141ec git-daemon.confd"
diff --git a/system/git/dont-test-other-encodings.patch b/system/git/dont-test-other-encodings.patch
index 9019d4cab..7d176d57a 100644
--- a/system/git/dont-test-other-encodings.patch
+++ b/system/git/dont-test-other-encodings.patch
@@ -1,140 +1,5 @@
We can't support Japanese people using musl
---- git-2.14.1/t/t3900-i18n-commit.sh.old 2017-08-09 14:54:31.000000000 -0500
-+++ git-2.14.1/t/t3900-i18n-commit.sh 2017-09-10 21:10:09.269860087 -0500
-@@ -76,132 +76,4 @@
- test_i18ngrep "did not conform" "$HOME"/stderr
- '
-
--for H in ISO8859-1 eucJP ISO-2022-JP
--do
-- test_expect_success "$H setup" '
-- git config i18n.commitencoding $H &&
-- git checkout -b $H C0 &&
-- echo $H >F &&
-- git commit -a -F "$TEST_DIRECTORY"/t3900/$H.txt
-- '
--done
--
--for H in ISO8859-1 eucJP ISO-2022-JP
--do
-- test_expect_success "check encoding header for $H" '
-- E=$(git cat-file commit '$H' | sed -ne "s/^encoding //p") &&
-- test "z$E" = "z'$H'"
-- '
--done
--
--test_expect_success 'config to remove customization' '
-- git config --unset-all i18n.commitencoding &&
-- if Z=$(git config --get-all i18n.commitencoding)
-- then
-- echo Oops, should have failed.
-- false
-- else
-- test z = "z$Z"
-- fi &&
-- git config i18n.commitencoding UTF-8
--'
--
--test_expect_success 'ISO8859-1 should be shown in UTF-8 now' '
-- compare_with ISO8859-1 "$TEST_DIRECTORY"/t3900/1-UTF-8.txt
--'
--
--for H in eucJP ISO-2022-JP
--do
-- test_expect_success "$H should be shown in UTF-8 now" '
-- compare_with '$H' "$TEST_DIRECTORY"/t3900/2-UTF-8.txt
-- '
--done
--
--test_expect_success 'config to add customization' '
-- git config --unset-all i18n.commitencoding &&
-- if Z=$(git config --get-all i18n.commitencoding)
-- then
-- echo Oops, should have failed.
-- false
-- else
-- test z = "z$Z"
-- fi
--'
--
--for H in ISO8859-1 eucJP ISO-2022-JP
--do
-- test_expect_success "$H should be shown in itself now" '
-- git config i18n.commitencoding '$H' &&
-- compare_with '$H' "$TEST_DIRECTORY"/t3900/'$H'.txt
-- '
--done
--
--test_expect_success 'config to tweak customization' '
-- git config i18n.logoutputencoding UTF-8
--'
--
--test_expect_success 'ISO8859-1 should be shown in UTF-8 now' '
-- compare_with ISO8859-1 "$TEST_DIRECTORY"/t3900/1-UTF-8.txt
--'
--
--for H in eucJP ISO-2022-JP
--do
-- test_expect_success "$H should be shown in UTF-8 now" '
-- compare_with '$H' "$TEST_DIRECTORY"/t3900/2-UTF-8.txt
-- '
--done
--
--for J in eucJP ISO-2022-JP
--do
-- if test "$J" = ISO-2022-JP
-- then
-- ICONV=$J
-- else
-- ICONV=
-- fi
-- git config i18n.logoutputencoding $J
-- for H in eucJP ISO-2022-JP
-- do
-- test_expect_success "$H should be shown in $J now" '
-- compare_with '$H' "$TEST_DIRECTORY"/t3900/'$J'.txt $ICONV
-- '
-- done
--done
--
--for H in ISO8859-1 eucJP ISO-2022-JP
--do
-- test_expect_success "No conversion with $H" '
-- compare_with "--encoding=none '$H'" "$TEST_DIRECTORY"/t3900/'$H'.txt
-- '
--done
--
--test_commit_autosquash_flags () {
-- H=$1
-- flag=$2
-- test_expect_success "commit --$flag with $H encoding" '
-- git config i18n.commitencoding $H &&
-- git checkout -b $H-$flag C0 &&
-- echo $H >>F &&
-- git commit -a -F "$TEST_DIRECTORY"/t3900/$H.txt &&
-- test_tick &&
-- echo intermediate stuff >>G &&
-- git add G &&
-- git commit -a -m "intermediate commit" &&
-- test_tick &&
-- echo $H $flag >>F &&
-- git commit -a --$flag HEAD~1 &&
-- E=$(git cat-file commit '$H-$flag' |
-- sed -ne "s/^encoding //p") &&
-- test "z$E" = "z$H" &&
-- git config --unset-all i18n.commitencoding &&
-- git rebase --autosquash -i HEAD^^^ &&
-- git log --oneline >actual &&
-- test_line_count = 3 actual
-- '
--}
--
--test_commit_autosquash_flags eucJP fixup
--
--test_commit_autosquash_flags ISO-2022-JP squash
--
- test_done
--- git-2.14.1/t/t5100-mailinfo.sh.old 2017-08-09 14:54:31.000000000 -0500
+++ git-2.14.1/t/t5100-mailinfo.sh 2017-09-10 23:26:39.206126739 -0500
@@ -27,6 +27,7 @@