summaryrefslogtreecommitdiff
path: root/user/abiword/APKBUILD
diff options
context:
space:
mode:
authormultiplexd <multi@in-addr.xyz>2019-01-07 20:45:49 +0000
committermultiplexd <multi@in-addr.xyz>2019-01-07 21:22:49 +0000
commit677a7de7f445dad6dab7c8531029f3e45fab8a0a (patch)
tree83b0da1d1c5e56bb50a279a7250bbc0e605cece2 /user/abiword/APKBUILD
parentaaed1d384ec219669ec3680e1f9e6b3a42d775e0 (diff)
downloadpackages-677a7de7f445dad6dab7c8531029f3e45fab8a0a.tar.gz
packages-677a7de7f445dad6dab7c8531029f3e45fab8a0a.tar.bz2
packages-677a7de7f445dad6dab7c8531029f3e45fab8a0a.tar.xz
packages-677a7de7f445dad6dab7c8531029f3e45fab8a0a.zip
user/abiword: new package
Diffstat (limited to 'user/abiword/APKBUILD')
-rw-r--r--user/abiword/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/user/abiword/APKBUILD b/user/abiword/APKBUILD
new file mode 100644
index 000000000..351961055
--- /dev/null
+++ b/user/abiword/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: multiplexd <multi@in-addr.xyz>
+pkgname=abiword
+pkgver=3.0.2
+pkgrel=0
+pkgdesc="A fully-featured word processor"
+url="https://www.abisource.com"
+arch="all"
+options="!check" # Test suite requires valgrind, etc
+license="GPL-2.0+"
+makedepends="bzip2-dev enchant-dev fribidi-dev goffice-dev gtk+3.0-dev
+ libgsf-dev libjpeg-turbo-dev librsvg-dev libxslt-dev pcre-dev
+ popt-dev wv-dev"
+
+# openxml plugin
+makedepends="$makedepends boost-dev"
+
+# collab plugin
+makedepends="$makedepends gnutls-dev libsoup-dev dbus-glib-dev"
+
+subpackages="$pkgname-dev $pkgname-doc"
+
+_plugins="applix babelfish bmp clarisworks collab docbook eml epub \
+ freetranslation garble gdict gimp google hancom hrtext iscii kword \
+ latex loadbindings mht mif mswrite openwriter openxml opml paint \
+ passepartout pdb pdf presentation s5 sdw t602 urldict wikipedia wml \
+ xslfo"
+
+source="https://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz
+ fix-black-drawing-regression.patch"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --enable-shared \
+ --disable-static \
+ --enable-plugins="$_plugins"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="29ce9e80b3b85ab2933e7d39216771d8c4e05db5255eaed0cf8e1d032ffaac2cb1880bf24e754196ad5dae4969a1c2101ce4dc9c1db14604adc2f852b6a17fe3 abiword-3.0.2.tar.gz
+cae9a08047cd97d11acea25a2f0b0ca4e8e4556b462eb476507fa178a7412221839febfeb36bebf491bb94d53525c4584d86230f96c403a7ceb2dec4223be8fe fix-black-drawing-regression.patch"