summaryrefslogtreecommitdiff
path: root/user/acpilight
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-01-13 10:02:29 +0000
committerMax Rees <maxcrees@me.com>2018-03-24 20:58:03 +0000
commit2ae7465964126c09aa2e318e27d37769126c8fa9 (patch)
treebf92b26541a8e804f33865c7615eb715ceae2026 /user/acpilight
parent3441bac816246d1f0a38fe24170389b6f4a341ce (diff)
downloadpackages-2ae7465964126c09aa2e318e27d37769126c8fa9.tar.gz
packages-2ae7465964126c09aa2e318e27d37769126c8fa9.tar.bz2
packages-2ae7465964126c09aa2e318e27d37769126c8fa9.tar.xz
packages-2ae7465964126c09aa2e318e27d37769126c8fa9.zip
user/acpilight: new package
Diffstat (limited to 'user/acpilight')
-rw-r--r--user/acpilight/APKBUILD36
-rw-r--r--user/acpilight/acpilight.post-install11
-rw-r--r--user/acpilight/python3.patch22
-rw-r--r--user/acpilight/rules-warning.patch8
4 files changed, 77 insertions, 0 deletions
diff --git a/user/acpilight/APKBUILD b/user/acpilight/APKBUILD
new file mode 100644
index 000000000..97956accd
--- /dev/null
+++ b/user/acpilight/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=acpilight
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="Control backlight brightness level"
+url="https://github.com/wavexx/acpilight"
+arch="noarch"
+license="GPL-3.0"
+depends="eudev python3"
+makedepends=""
+install="$pkgname.post-install"
+subpackages="$pkgname-doc"
+options="!check" # Just a udev rule and a python script
+source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz
+ python3.patch
+ rules-warning.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 xbacklight \
+ "$pkgdir/usr/bin/xbacklight"
+ install -Dm644 90-backlight.rules \
+ "$pkgdir/lib/udev/rules.d/90-$pkgname.rules"
+ install -Dm644 xbacklight.1 \
+ "$pkgdir/usr/share/man/man1/xbacklight.1"
+}
+
+sha512sums="c9b5805f919172d4806942ba1987d0c11fda420a807c45c404eda83cbcfc6011729b09d7ae3113106e006d2ed65ab26e4932869305e48d9493514b597c6e9713 acpilight-1.0.1.tar.gz
+9ed3bc124a0120d7d4ea8831e7bef715c5c45b3e3389aed55261cf436db8cb123a8bffe463a29107cb27161a59ed6a31623e23f2b55797c99be92a2d26eabca0 python3.patch
+63521df95b943c941c6687960b69f4ca51f2b36c3d390ef50738034f13afbab175b0a69c7874bc47bc85a1b8d877a26427eba3a264803b700ff652c3c28cd2ad rules-warning.patch"
diff --git a/user/acpilight/acpilight.post-install b/user/acpilight/acpilight.post-install
new file mode 100644
index 000000000..0e64cf725
--- /dev/null
+++ b/user/acpilight/acpilight.post-install
@@ -0,0 +1,11 @@
+#!/bin/sh
+chgrp video /sys/class/backlight/*/brightness || true
+chmod g+w /sys/class/backlight/*/brightness || true
+chgrp video /sys/class/leds/*/brightness || true
+chmod g+w /sys/class/leds/*/brightness || true
+
+echo "*"
+echo "* Any user wishing to use xbacklight must be in the 'video' group."
+echo "* Check using 'groups \$USER' and add using 'usermod -aG video \$USER'."
+echo "*"
+exit 0
diff --git a/user/acpilight/python3.patch b/user/acpilight/python3.patch
new file mode 100644
index 000000000..ab0ffe61f
--- /dev/null
+++ b/user/acpilight/python3.patch
@@ -0,0 +1,22 @@
+--- acpilight-1.0/xbacklight 2017-02-23 21:03:30.000000000 +0000
++++ acpilight-1.0/xbacklight 2018-01-13 08:52:42.400000000 +0000
+@@ -1,9 +1,8 @@
+-#!/usr/bin/env python
++#!/usr/bin/python3
+ # xbacklight: control backlight and led brightness on linux using the sys
+ # filesystem with a backward-compatibile user interface
+ # Copyright(c) 2016-2017 by wave++ "Yuri D'Elia" <wavexx@thregr.org>
+ # -*- coding: utf-8 -*-
+-from __future__ import print_function, division, generators
+
+ APP_DESC = "control backlight brightness"
+ SYS_PATH = ["/sys/class/backlight", "/sys/class/leds"]
+@@ -99,7 +98,7 @@
+
+ # set current operating controller
+ if args.ctrl is None:
+- ctrl = Controller(next(iter(ctrls.values())))
++ ctrl = Controller(next(iter(list(ctrls.values()))))
+ else:
+ if args.ctrl not in ctrls:
+ error("unknown controller '{}'".format(args.ctrl))
diff --git a/user/acpilight/rules-warning.patch b/user/acpilight/rules-warning.patch
new file mode 100644
index 000000000..45c7abacb
--- /dev/null
+++ b/user/acpilight/rules-warning.patch
@@ -0,0 +1,8 @@
+--- acpilight-1.0/90-backlight.rules 2017-02-23 21:03:30.000000000 +0000
++++ acpilight-1.0/90-backlight.rules 2018-01-13 09:14:11.290000000 +0000
+@@ -1,4 +1,5 @@
+ # Allow video group to control backlight and leds
++# do not edit this file, it will be overwritten on update
+ SUBSYSTEM=="backlight", ACTION=="add", \
+ RUN+="/bin/chgrp video %S%p/brightness", \
+ RUN+="/bin/chmod g+w %S%p/brightness"