summaryrefslogtreecommitdiff
path: root/user/acpilight
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-09-03 20:28:23 -0400
committerMax Rees <maxcrees@me.com>2018-09-03 20:28:23 -0400
commitba5e579183ed74b8b3fb1f25d72af5693e833a60 (patch)
treeed3737a290c278406ad47ff615f46237e6684671 /user/acpilight
parent859e0988612b06174e8389369df1c7de8f7a65b3 (diff)
downloadpackages-ba5e579183ed74b8b3fb1f25d72af5693e833a60.tar.gz
packages-ba5e579183ed74b8b3fb1f25d72af5693e833a60.tar.bz2
packages-ba5e579183ed74b8b3fb1f25d72af5693e833a60.tar.xz
packages-ba5e579183ed74b8b3fb1f25d72af5693e833a60.zip
user/acpilight: fix license, change URL, upgrade to 1.1
Diffstat (limited to 'user/acpilight')
-rw-r--r--user/acpilight/APKBUILD16
-rw-r--r--user/acpilight/acpilight.post-install5
-rw-r--r--user/acpilight/python3.patch22
-rw-r--r--user/acpilight/rules-warning.patch8
4 files changed, 12 insertions, 39 deletions
diff --git a/user/acpilight/APKBUILD b/user/acpilight/APKBUILD
index 97956accd..f81e93e37 100644
--- a/user/acpilight/APKBUILD
+++ b/user/acpilight/APKBUILD
@@ -1,21 +1,20 @@
# Contributor: Max Rees <maxcrees@me.com>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=acpilight
-pkgver=1.0.1
+pkgver=1.1
pkgrel=0
pkgdesc="Control backlight brightness level"
-url="https://github.com/wavexx/acpilight"
+url="https://gitlab.com/wavexx/acpilight"
arch="noarch"
-license="GPL-3.0"
+license="GPL-3.0+"
depends="eudev python3"
makedepends=""
install="$pkgname.post-install"
subpackages="$pkgname-doc"
options="!check" # Just a udev rule and a python script
-source="$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz
- python3.patch
+source="https://gitlab.com/wavexx/acpilight/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz
rules-warning.patch"
-builddir="$srcdir/$pkgname-$pkgver"
+builddir="$srcdir/$pkgname-v$pkgver"
build() {
cd "$builddir"
@@ -31,6 +30,5 @@ package() {
"$pkgdir/usr/share/man/man1/xbacklight.1"
}
-sha512sums="c9b5805f919172d4806942ba1987d0c11fda420a807c45c404eda83cbcfc6011729b09d7ae3113106e006d2ed65ab26e4932869305e48d9493514b597c6e9713 acpilight-1.0.1.tar.gz
-9ed3bc124a0120d7d4ea8831e7bef715c5c45b3e3389aed55261cf436db8cb123a8bffe463a29107cb27161a59ed6a31623e23f2b55797c99be92a2d26eabca0 python3.patch
-63521df95b943c941c6687960b69f4ca51f2b36c3d390ef50738034f13afbab175b0a69c7874bc47bc85a1b8d877a26427eba3a264803b700ff652c3c28cd2ad rules-warning.patch"
+sha512sums="af10a538fec83315aaec3837647622ecea41cb936d38667e4e70689a2b8a968a786fc9ad2be136d5799fa091f07614886decc9044e71aec1e64765e90ddae439 acpilight-v1.1.tar.gz
+1b04e8c92bd39f2230b351fc15c63a303f71768ebce58fff5ed3d99fcbc38b417a61214227ab8612e6212d8db775dad2b5f9bad58fddf57452e2ff2cfa4fd077 rules-warning.patch"
diff --git a/user/acpilight/acpilight.post-install b/user/acpilight/acpilight.post-install
index 0e64cf725..958c8dbd3 100644
--- a/user/acpilight/acpilight.post-install
+++ b/user/acpilight/acpilight.post-install
@@ -1,8 +1,5 @@
#!/bin/sh
-chgrp video /sys/class/backlight/*/brightness || true
-chmod g+w /sys/class/backlight/*/brightness || true
-chgrp video /sys/class/leds/*/brightness || true
-chmod g+w /sys/class/leds/*/brightness || true
+udevadm trigger -s backlight -c add
echo "*"
echo "* Any user wishing to use xbacklight must be in the 'video' group."
diff --git a/user/acpilight/python3.patch b/user/acpilight/python3.patch
deleted file mode 100644
index ab0ffe61f..000000000
--- a/user/acpilight/python3.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- acpilight-1.0/xbacklight 2017-02-23 21:03:30.000000000 +0000
-+++ acpilight-1.0/xbacklight 2018-01-13 08:52:42.400000000 +0000
-@@ -1,9 +1,8 @@
--#!/usr/bin/env python
-+#!/usr/bin/python3
- # xbacklight: control backlight and led brightness on linux using the sys
- # filesystem with a backward-compatibile user interface
- # Copyright(c) 2016-2017 by wave++ "Yuri D'Elia" <wavexx@thregr.org>
- # -*- coding: utf-8 -*-
--from __future__ import print_function, division, generators
-
- APP_DESC = "control backlight brightness"
- SYS_PATH = ["/sys/class/backlight", "/sys/class/leds"]
-@@ -99,7 +98,7 @@
-
- # set current operating controller
- if args.ctrl is None:
-- ctrl = Controller(next(iter(ctrls.values())))
-+ ctrl = Controller(next(iter(list(ctrls.values()))))
- else:
- if args.ctrl not in ctrls:
- error("unknown controller '{}'".format(args.ctrl))
diff --git a/user/acpilight/rules-warning.patch b/user/acpilight/rules-warning.patch
index 45c7abacb..749bf8ac8 100644
--- a/user/acpilight/rules-warning.patch
+++ b/user/acpilight/rules-warning.patch
@@ -1,8 +1,8 @@
---- acpilight-1.0/90-backlight.rules 2017-02-23 21:03:30.000000000 +0000
-+++ acpilight-1.0/90-backlight.rules 2018-01-13 09:14:11.290000000 +0000
+--- acpilight-v1.1/90-backlight.rules 2018-06-21 14:09:44.000000000 +0000
++++ acpilight-v1.1/90-backlight.rules 2018-09-04 00:12:34.839762243 +0000
@@ -1,4 +1,5 @@
# Allow video group to control backlight and leds
+# do not edit this file, it will be overwritten on update
SUBSYSTEM=="backlight", ACTION=="add", \
- RUN+="/bin/chgrp video %S%p/brightness", \
- RUN+="/bin/chmod g+w %S%p/brightness"
+ RUN+="/bin/chgrp video /sys/class/backlight/%k/brightness", \
+ RUN+="/bin/chmod g+w /sys/class/backlight/%k/brightness"