summaryrefslogtreecommitdiff
path: root/user/adelie-kde-theme
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-15 22:05:49 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-15 22:06:08 +0000
commitd1ba3b521c32759829b7816a7bd45a5bd092c1bc (patch)
tree8bfbc53e41c294ff344d4d78dc4bd57f1881b058 /user/adelie-kde-theme
parent7a77b262ed0a91b879e934353f368ae2679c51e4 (diff)
downloadpackages-d1ba3b521c32759829b7816a7bd45a5bd092c1bc.tar.gz
packages-d1ba3b521c32759829b7816a7bd45a5bd092c1bc.tar.bz2
packages-d1ba3b521c32759829b7816a7bd45a5bd092c1bc.tar.xz
packages-d1ba3b521c32759829b7816a7bd45a5bd092c1bc.zip
user/adelie-kde-theme: update theme
Diffstat (limited to 'user/adelie-kde-theme')
-rw-r--r--user/adelie-kde-theme/APKBUILD19
-rw-r--r--user/adelie-kde-theme/adelie-kde-theme.js33
-rw-r--r--user/adelie-kde-theme/kdeglobals3
-rw-r--r--user/adelie-kde-theme/kscreenlockerrc13
-rw-r--r--user/adelie-kde-theme/kwinrc3
5 files changed, 61 insertions, 10 deletions
diff --git a/user/adelie-kde-theme/APKBUILD b/user/adelie-kde-theme/APKBUILD
index 047bfd4ca..5eb3e9509 100644
--- a/user/adelie-kde-theme/APKBUILD
+++ b/user/adelie-kde-theme/APKBUILD
@@ -2,22 +2,27 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=adelie-kde-theme
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc="The Adélie Linux official KDE theme"
url="https://adelielinux.org/"
arch="noarch"
options="!check" # No test suite.
license="NCSA"
-depends="corindon-red papirus-icons"
+depends="adelie-wallpapers papirus-icons"
source="kdeglobals
- kwinrc"
+ kscreenlockerrc
+ adelie-kde-theme.js
+ "
builddir="$srcdir/"
package() {
cd "$builddir"
- install -D -m644 kwinrc "$pkgdir"/etc/xdg/kwinrc
- install -m 644 kdeglobals "$pkgdir"/etc/xdg/kdeglobals
+ install -D -m644 kdeglobals "$pkgdir"/etc/xdg/kdeglobals
+ install -m644 kscreenlockerrc "$pkgdir"/etc/xdg/kscreenlockerrc
+ install -D -m644 adelie-kde-theme.js \
+ "$pkgdir"/usr/share/plasma/shells/org.kde.plasma.desktop/contents/updates/adelie-kde-theme.js
}
-sha512sums="f54683f11ff8fd800a936a2072626a5020d4519b7796a52a193be28a0961c64294441553ed14d7c91d12a336449e6735364509ac4f1bf8213af97d29708d4b4e kdeglobals
-b889ed3b4e79cc4c073947042f10505ab044c4740fea2391e1d8dfec1aaff75e65420a2872a787b321e4862dded6b2f6aea806b5027ba86be2808f79786efe93 kwinrc"
+sha512sums="ed5dfa83a4d2f6b171b3a3238dea626b9ca9e1afd72ae026ef680a5eef0c3fff4aaf7c82f4bf394c26d002fde7517a4c842f9bdb9059107200d17f48e432b940 kdeglobals
+b94c261d2ce098af1c1856f92b20485167be4f59b66fd3a47379d339a21b4c7a9c274dca2964bbc5f2adff74e514eb73e988db749e22d35817f37b10303fecca kscreenlockerrc
+05a4649938755b3b3c058d6a7507065e07ba29ac448d314db3fc93623008eb1903ae5bcc9c62d0b29b37dd0e85246bc2dbfc2792c69e0f387e99683275db09cd adelie-kde-theme.js"
diff --git a/user/adelie-kde-theme/adelie-kde-theme.js b/user/adelie-kde-theme/adelie-kde-theme.js
new file mode 100644
index 000000000..596d386b5
--- /dev/null
+++ b/user/adelie-kde-theme/adelie-kde-theme.js
@@ -0,0 +1,33 @@
+// Copyright 2016 Aurélien COUDERC <zecoucou@free.fr>
+//
+// This program is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// This program is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+// This script is provided by desktop-base
+// It is run by Plasma 5 on upgrade.
+// Plasma checks that the script is only run once for each version.
+desktops = desktops()
+
+for (desktop in desktops) {
+ // Only set up the wallpaper if the plugin is the default.
+ // Otherwise it means the user chose another plugin and we don’t want to override that.
+ if (desktops[desktop].wallpaperPlugin == 'org.kde.image') {
+ desktops[desktop].currentConfigGroup = Array('Wallpaper', 'org.kde.image', 'General')
+ if (!desktops[desktop].readConfig('Image')) {
+ // Only set up the wallpaper if the wallpaper image is empty (=default).
+ // Otherwise it means the user selected a picture and we don’t want to override that.
+ desktops[desktop].writeConfig('Image', 'Sunset');
+ }
+ }
+}
+
diff --git a/user/adelie-kde-theme/kdeglobals b/user/adelie-kde-theme/kdeglobals
index bb7802e93..2ec479dc2 100644
--- a/user/adelie-kde-theme/kdeglobals
+++ b/user/adelie-kde-theme/kdeglobals
@@ -3,3 +3,6 @@ ColorScheme=Steel
[Icons]
Theme=Papirus
+
+[WM]
+activeBackground=104,0,0
diff --git a/user/adelie-kde-theme/kscreenlockerrc b/user/adelie-kde-theme/kscreenlockerrc
new file mode 100644
index 000000000..54b5cbd92
--- /dev/null
+++ b/user/adelie-kde-theme/kscreenlockerrc
@@ -0,0 +1,13 @@
+[$Version]
+update_info=kscreenlocker.upd:0.1-autolock
+
+[Greeter]
+WallpaperPlugin=org.kde.image
+
+[Greeter][Wallpaper][org.kde.color][General]
+Color=128,0,0
+
+[Greeter][Wallpaper][org.kde.image][General]
+Color=128,0,0
+FillMode=1
+Image=LockScreen
diff --git a/user/adelie-kde-theme/kwinrc b/user/adelie-kde-theme/kwinrc
deleted file mode 100644
index 0c9b9c589..000000000
--- a/user/adelie-kde-theme/kwinrc
+++ /dev/null
@@ -1,3 +0,0 @@
-[org.kde.kdecoration2]
-library=org.kde.kwin.aurorae
-theme=__aurorae__svg__corindon-red