summaryrefslogtreecommitdiff
path: root/user/alsa-lib
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-03-17 01:38:28 -0500
committerMax Rees <maxcrees@me.com>2020-03-17 01:57:23 -0500
commitd2c42701a5f3df158206221709b2bfdd4715fcd4 (patch)
treeff0efd334a33404f278701b486e3abec0b2b3521 /user/alsa-lib
parentbd3f8f4faafb5875993337e39ef90d8cf6f5f5fb (diff)
downloadpackages-d2c42701a5f3df158206221709b2bfdd4715fcd4.tar.gz
packages-d2c42701a5f3df158206221709b2bfdd4715fcd4.tar.bz2
packages-d2c42701a5f3df158206221709b2bfdd4715fcd4.tar.xz
packages-d2c42701a5f3df158206221709b2bfdd4715fcd4.zip
user/alsa-lib: bump to 1.2.2
Diffstat (limited to 'user/alsa-lib')
-rw-r--r--user/alsa-lib/APKBUILD9
-rw-r--r--user/alsa-lib/type_compat.patch23
2 files changed, 29 insertions, 3 deletions
diff --git a/user/alsa-lib/APKBUILD b/user/alsa-lib/APKBUILD
index 4f854e443..49f14066e 100644
--- a/user/alsa-lib/APKBUILD
+++ b/user/alsa-lib/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=alsa-lib
-pkgver=1.2.1.2
+pkgver=1.2.2
pkgrel=0
pkgdesc="Linux sound support system"
url="https://www.alsa-project.org/wiki/Main_Page"
@@ -12,6 +12,7 @@ subpackages="$pkgname-dev $pkgname-dbg"
source="ftp://ftp.alsa-project.org/pub/lib/$pkgname-$pkgver.tar.bz2
ucm_add_limits_h.patch
remove-test.patch
+ type_compat.patch
"
build() {
@@ -30,6 +31,7 @@ build() {
rm -rf "$builddir"/include/sound
mkdir "$builddir"/include/sound
printf "all:\ncheck:\ninstall:\n" > "$builddir"/include/sound/Makefile
+
make
}
@@ -41,6 +43,7 @@ package() {
make -j1 DESTDIR="$pkgdir" install
}
-sha512sums="e8286fd55f63ee0d95513279d0885c287533de89b7af6c338413dec5d38ba4f5a15da1a4a4ce36e052614e4b730e3778782dab9979d82958283be17b48604913 alsa-lib-1.2.1.2.tar.bz2
+sha512sums="d21adb3ff998918c7d1820f9ce2aaf4202dd45ccb87cb092d49da8b2402b6ddaad06325be0fd59f17393a5d9958e3743bfccb4b14bdb947a42e7d791d73c7033 alsa-lib-1.2.2.tar.bz2
3b37652d50809443b5f8e80f8d447108195b0cd66fd917805bb393fc091584b6f3dad4414f568742b61745617e7a695862058a0a0f93dcc31e4c97177a520352 ucm_add_limits_h.patch
-0ce3c2b8a0a70e2dffb6d633b95c4aae74504cd694fe1507cbc409d931b5f733935b22de45e4adcf5a507587c9f80c60a6f0e798aac2ca2fbf0cbcdef0080079 remove-test.patch"
+0ce3c2b8a0a70e2dffb6d633b95c4aae74504cd694fe1507cbc409d931b5f733935b22de45e4adcf5a507587c9f80c60a6f0e798aac2ca2fbf0cbcdef0080079 remove-test.patch
+bdcfa3d5fcc055fb6732922679e21689fc2ac19462fe7b72d16862c98ef8c995c3dd5becc4987ba417068e6b0e561bec7e6284d5f0a414e2966c8e00ac304fa8 type_compat.patch"
diff --git a/user/alsa-lib/type_compat.patch b/user/alsa-lib/type_compat.patch
new file mode 100644
index 000000000..4236d11d4
--- /dev/null
+++ b/user/alsa-lib/type_compat.patch
@@ -0,0 +1,23 @@
+Since we force the use of the uapi headers from linux-headers instead of
+using the vendored copy, type_compat.h never gets put in the place it
+should be for it to be seen in sound/.
+
+However, the only reason it was included here anyway was to replace a
+definition that was never used:
+
+https://github.com/alsa-project/alsa-lib/commit/ae564665ec261cf104de499b1cdda3564070fc65#diff-5e0b4d8ecf374a31036ffc7b224d5e7fL21
+
+ -#define __packed __attribute__((__packed__))
+ -
+ +#include <sound/type_compat.h>
+
+--- alsa-lib-1.2.2/src/topology/tplg_local.h 2020-02-19 03:35:39.000000000 -0600
++++ alsa-lib-1.2.2/src/topology/tplg_local.h 2020-03-17 01:26:25.159548858 -0500
+@@ -18,7 +18,6 @@
+ #include "list.h"
+ #include "topology.h"
+
+-#include <sound/type_compat.h>
+ #include <sound/asound.h>
+ #include <sound/asoc.h>
+ #include <sound/tlv.h>