summaryrefslogtreecommitdiff
path: root/user/alsa-utils
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-07-22 20:15:07 -0400
committerMax Rees <maxcrees@me.com>2019-07-22 20:15:07 -0400
commit2707df6cc761dcc2341faa8bafec5b4b4fa33e4d (patch)
tree9df7c2d2fd84f153634581ff4fb249b98bf34ffa /user/alsa-utils
parentb7ffaa4d55e1faf4de0f8e6a2edf372fedfeaf71 (diff)
downloadpackages-2707df6cc761dcc2341faa8bafec5b4b4fa33e4d.tar.gz
packages-2707df6cc761dcc2341faa8bafec5b4b4fa33e4d.tar.bz2
packages-2707df6cc761dcc2341faa8bafec5b4b4fa33e4d.tar.xz
packages-2707df6cc761dcc2341faa8bafec5b4b4fa33e4d.zip
system/*, user/*: remove bashisms from initd scripts
Diffstat (limited to 'user/alsa-utils')
-rw-r--r--user/alsa-utils/APKBUILD4
-rw-r--r--user/alsa-utils/alsa.initd4
2 files changed, 4 insertions, 4 deletions
diff --git a/user/alsa-utils/APKBUILD b/user/alsa-utils/APKBUILD
index 835c37b43..057e77cc1 100644
--- a/user/alsa-utils/APKBUILD
+++ b/user/alsa-utils/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=alsa-utils
pkgver=1.1.9
-pkgrel=0
+pkgrel=1
pkgdesc="Advanced Linux Sound Architecture (ALSA) utilities"
url="https://www.alsa-project.org/wiki/Main_Page"
arch="all"
@@ -38,5 +38,5 @@ package() {
sha512sums="92fa689ea5897150972d5376e7999ff060cad09cb0b06991d81c87b61a243ecec944e2a4c7ad38878596cd8b4246e44c5a3a35e5bc6452c02ebf35c9bed91970 alsa-utils-1.1.9.tar.bz2
817215be6e9f103a8a187df5b1142c4d2e952f547a64579a9b8cfa58bd762d6a55bde75c0f66f018c0597744d07ccdb08216f7b368db464e36667cecedcc00f3 alsaconf.patch
-8a52e6363d5dcfb16e1e607e1af3e46a2148989689e5ab04caf05f84dc68b34cc003b1cf0945ce2c3670cc7f3ef0e40824f689f1efa2d09177c82b13571a7168 alsa.initd
+7bf743024d7c5caed2fbf8af5cee73bcc569a7bab0bd6459541d3704cc6a7456d588b600b690e7406e122deaf0316dd1f67219a267bec4dff3f6c0f120edaae4 alsa.initd
6e716e6230fd3d2c33e3cb2dbf572d632c9ac6452c1768388bea7d3ca22f7c72cf6bcd702580f45cb9089983582011c8b04cbdb4420d14fb988167b1391ea547 alsa.confd"
diff --git a/user/alsa-utils/alsa.initd b/user/alsa-utils/alsa.initd
index e0a1215cf..1266b6624 100644
--- a/user/alsa-utils/alsa.initd
+++ b/user/alsa-utils/alsa.initd
@@ -39,7 +39,7 @@ restore() {
for ossfile in "${alsastatedir}"/oss/card*_pcm* ; do
[ -e "${ossfile}" ] || continue
# We use cat because I'm not sure if cp works properly on /proc
- local procfile=${ossfile##${alsastatedir}/oss}
+ local procfile="${ossfile##${alsastatedir}/oss}"
procfile="$(echo "${procfile}" | sed -e 's,_,/,g')"
if [ -e /proc/asound/"${procfile}"/oss ] ; then
cat "${ossfile}" > /proc/asound/"${procfile}"/oss
@@ -63,7 +63,7 @@ save() {
for ossfile in /proc/asound/card*/pcm*/oss; do
[ -e "${ossfile}" ] || continue
- local device=${ossfile##/proc/asound/} ; device=${device%%/oss}
+ local device="${ossfile##/proc/asound/}" ; device="${device%%/oss}"
device="$(echo "${device}" | sed -e 's,/,_,g')"
mkdir -p "${alsastatedir}/oss/"
cp "${ossfile}" "${alsastatedir}/oss/${device}"