summaryrefslogtreecommitdiff
path: root/user/argp-standalone
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-18 23:40:46 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-18 23:40:46 -0500
commit26310cd455ee446af79dae44cd1a845df6d3794d (patch)
treea7de9cb0739f6c7d7af94d496f0b29a1cc00e3be /user/argp-standalone
parent8bcd602eb7b573a1154eb4e826647491080ae2de (diff)
downloadpackages-26310cd455ee446af79dae44cd1a845df6d3794d.tar.gz
packages-26310cd455ee446af79dae44cd1a845df6d3794d.tar.bz2
packages-26310cd455ee446af79dae44cd1a845df6d3794d.tar.xz
packages-26310cd455ee446af79dae44cd1a845df6d3794d.zip
user/argp-standalone: pull in, fix up, fix license
Diffstat (limited to 'user/argp-standalone')
-rw-r--r--user/argp-standalone/001-throw-in-funcdef.patch79
-rw-r--r--user/argp-standalone/APKBUILD49
-rw-r--r--user/argp-standalone/gnu89-inline.patch22
3 files changed, 150 insertions, 0 deletions
diff --git a/user/argp-standalone/001-throw-in-funcdef.patch b/user/argp-standalone/001-throw-in-funcdef.patch
new file mode 100644
index 000000000..4a90751e1
--- /dev/null
+++ b/user/argp-standalone/001-throw-in-funcdef.patch
@@ -0,0 +1,79 @@
+# --- T2-COPYRIGHT-NOTE-BEGIN ---
+# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
+#
+# T2 SDE: package/.../rng-tools/throw-in-funcdef.patch.argp-standalone
+# Copyright (C) 2006 The T2 SDE Project
+#
+# More information can be found in the files COPYING and README.
+#
+# This patch file is dual-licensed. It is available under the license the
+# patched project is licensed under, as long as it is an OpenSource license
+# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
+# of the GNU General Public License as published by the Free Software
+# Foundation; either version 2 of the License, or (at your option) any later
+# version.
+# --- T2-COPYRIGHT-NOTE-END ---
+
+
+No __THROW in function implementation.
+ --jsaw
+
+--- argp-standalone-1.4-test2/argp.h.orig 2006-01-06 02:29:59.000000000 +0100
++++ argp-standalone-1.4-test2/argp.h 2006-01-06 02:41:10.000000000 +0100
+@@ -560,17 +560,17 @@
+ # endif
+
+ # ifndef ARGP_EI
+-# define ARGP_EI extern __inline__
++# define ARGP_EI extern inline
+ # endif
+
+ ARGP_EI void
+-__argp_usage (__const struct argp_state *__state) __THROW
++__argp_usage (__const struct argp_state *__state)
+ {
+ __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
+ }
+
+ ARGP_EI int
+-__option_is_short (__const struct argp_option *__opt) __THROW
++__option_is_short (__const struct argp_option *__opt)
+ {
+ if (__opt->flags & OPTION_DOC)
+ return 0;
+@@ -582,7 +582,7 @@
+ }
+
+ ARGP_EI int
+-__option_is_end (__const struct argp_option *__opt) __THROW
++__option_is_end (__const struct argp_option *__opt)
+ {
+ return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
+ }
+--- argp-standalone-1.4-test2/argp-parse.c.orig 2006-01-06 02:47:48.000000000 +0100
++++ argp-standalone-1.4-test2/argp-parse.c 2006-01-06 02:48:16.000000000 +0100
+@@ -1290,13 +1290,13 @@
+ /* Defined here, in case a user is not inlining the definitions in
+ * argp.h */
+ void
+-__argp_usage (__const struct argp_state *__state) __THROW
++__argp_usage (__const struct argp_state *__state)
+ {
+ __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
+ }
+
+ int
+-__option_is_short (__const struct argp_option *__opt) __THROW
++__option_is_short (__const struct argp_option *__opt)
+ {
+ if (__opt->flags & OPTION_DOC)
+ return 0;
+@@ -1310,7 +1310,7 @@
+ }
+
+ int
+-__option_is_end (__const struct argp_option *__opt) __THROW
++__option_is_end (__const struct argp_option *__opt)
+ {
+ return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
+ }
diff --git a/user/argp-standalone/APKBUILD b/user/argp-standalone/APKBUILD
new file mode 100644
index 000000000..846ed4c61
--- /dev/null
+++ b/user/argp-standalone/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=argp-standalone
+pkgver=1.3
+pkgrel=4
+pkgdesc="Hierarchial argument parsing library broken out from glibc"
+url="http://www.lysator.liu.se/~nisse/misc/"
+arch="all"
+options="!dbg"
+license="LGPL-2.0+ AND Public-Domain"
+depends=""
+makedepends="libtool automake autoconf"
+source="http://www.lysator.liu.se/~nisse/misc/$pkgname-$pkgver.tar.gz
+ 001-throw-in-funcdef.patch
+ gnu89-inline.patch
+ "
+
+builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ default_prepare
+ cd "$builddir"
+ autoreconf -vif
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make -C "$builddir" check
+}
+
+package() {
+ cd "$builddir"
+ install -D -m644 argp.h "$pkgdir"/usr/include/argp.h
+ install -D -m755 libargp.a "$pkgdir"/usr/lib/libargp.a
+}
+
+sha512sums="58c3feb8852b90248fff39e49b5019bd0dcf646790c3eaf70c3262eb81dda31a61dc0a45963c7b4a010e80fc14b37288dcb3b3ef48d02f2d33dd72c1c62e62d9 argp-standalone-1.3.tar.gz
+5e4cdeeb16e6a4fb46a00ab95f3da9276ee554eec00bb2a05da7467961234ba3f9a630aafa7ceb5feb429a84ece8bf03b869fa996b86468f4716935a914c79a4 001-throw-in-funcdef.patch
+69f1d8a4fcd542346f98bc1fb7151db748483fc2f331c8c35114e0891d867b41c603ddaa5f3130aaaf1c640e02c51ac71cee71b62c09301b146812e9059e9ade gnu89-inline.patch"
diff --git a/user/argp-standalone/gnu89-inline.patch b/user/argp-standalone/gnu89-inline.patch
new file mode 100644
index 000000000..71978eba5
--- /dev/null
+++ b/user/argp-standalone/gnu89-inline.patch
@@ -0,0 +1,22 @@
+diff --git a/configure.ac b/configure.ac
+index 4658839..09f0267 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -79,16 +79,10 @@ AC_CHECK_DECLS([program_invocation_name, program_invocation_short_name],
+
+ # Set these flags *last*, or else the test programs won't compile
+ if test x$GCC = xyes ; then
+- # Using -ggdb3 makes (some versions of) Redhat's gcc-2.96 dump core
+- if "$CC" --version | grep '^2\.96$' 1>/dev/null 2>&1; then
+- true
+- else
+- CFLAGS="$CFLAGS -ggdb3"
+- fi
+ CFLAGS="$CFLAGS -Wall -W \
+ -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes \
+ -Waggregate-return \
+- -Wpointer-arith -Wbad-function-cast -Wnested-externs"
++ -Wpointer-arith -Wbad-function-cast -Wnested-externs -fgnu89-inline"
+ fi
+
+ CPPFLAGS="$CPPFLAGS -I$srcdir"