summaryrefslogtreecommitdiff
path: root/user/aspell
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-11 10:38:05 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-11 10:38:05 +0000
commit00aa49a062ccc758c333353409d4e4c0065a2482 (patch)
treee12629965c9ca825b72c6770f8c9f6bf418398e1 /user/aspell
parent2f6d8a7f0a6c07d4924ad293eae9fe7be1753664 (diff)
downloadpackages-00aa49a062ccc758c333353409d4e4c0065a2482.tar.gz
packages-00aa49a062ccc758c333353409d4e4c0065a2482.tar.bz2
packages-00aa49a062ccc758c333353409d4e4c0065a2482.tar.xz
packages-00aa49a062ccc758c333353409d4e4c0065a2482.zip
user/aspell: GCC 8 compilation fix
Diffstat (limited to 'user/aspell')
-rw-r--r--user/aspell/APKBUILD17
-rw-r--r--user/aspell/aspell-0.60.6.1-gcc7-fixes.patch34
2 files changed, 42 insertions, 9 deletions
diff --git a/user/aspell/APKBUILD b/user/aspell/APKBUILD
index 8da5b4041..88ab8a736 100644
--- a/user/aspell/APKBUILD
+++ b/user/aspell/APKBUILD
@@ -2,26 +2,26 @@
# Maintainer:
pkgname=aspell
pkgver=0.60.6.1
-pkgrel=14
+pkgrel=15
pkgdesc="Libre spell checker software"
url="http://aspell.net/"
arch="all"
license="LGPL-2.0+"
-subpackages="$pkgname-compat::noarch $pkgname-dev $pkgname-doc
- $pkgname-lang"
depends="perl"
makedepends="ncurses-dev perl"
provides="aspell-utils"
-source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-compat::noarch $pkgname-dev $pkgname-doc
+ $pkgname-lang"
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+ aspell-0.60.6.1-gcc7-fixes.patch
+ "
prepare() {
- cd "$builddir"
default_prepare
update_config_sub
}
build() {
- cd "$builddir"
LIBS="-ltinfo" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -34,12 +34,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -51,4 +49,5 @@ compat() {
mv spell ispell "$subpkgdir"/usr/bin/
}
-sha512sums="f310c7590be98406589b5c26ca36a2ecfe4733f0b40fd6c176b96b7955ef2b5cd0ec9a3d770cf132146ae7a896042b4b698945112995ee1ae66adcfa5542247f aspell-0.60.6.1.tar.gz"
+sha512sums="f310c7590be98406589b5c26ca36a2ecfe4733f0b40fd6c176b96b7955ef2b5cd0ec9a3d770cf132146ae7a896042b4b698945112995ee1ae66adcfa5542247f aspell-0.60.6.1.tar.gz
+7acdd483fa218952775282f42c28998b4901b1c70aeeef307835a205d1cde3fb2912898d08799ee596d744dde55d04e5c4905fb66d8bfa3028d1f5d45bb66d1e aspell-0.60.6.1-gcc7-fixes.patch"
diff --git a/user/aspell/aspell-0.60.6.1-gcc7-fixes.patch b/user/aspell/aspell-0.60.6.1-gcc7-fixes.patch
new file mode 100644
index 000000000..4eb825a24
--- /dev/null
+++ b/user/aspell/aspell-0.60.6.1-gcc7-fixes.patch
@@ -0,0 +1,34 @@
+commit 8089fa02122fed0a6394eba14bbedcb1d18e2384
+Author: Kevin Atkinson <kevina@gnu.org>
+Date: Thu Dec 29 00:50:31 2016 -0500
+
+ Compile Fixes for GCC 7.
+
+ Closes #519.
+
+diff --git a/modules/filter/tex.cpp b/modules/filter/tex.cpp
+index a979539..19ab63c 100644
+--- a/modules/filter/tex.cpp
++++ b/modules/filter/tex.cpp
+@@ -174,7 +174,7 @@ namespace {
+
+ if (c == '{') {
+
+- if (top.in_what == Parm || top.in_what == Opt || top.do_check == '\0')
++ if (top.in_what == Parm || top.in_what == Opt || *top.do_check == '\0')
+ push_command(Parm);
+
+ top.in_what = Parm;
+diff --git a/prog/check_funs.cpp b/prog/check_funs.cpp
+index db54f3d..89ee09d 100644
+--- a/prog/check_funs.cpp
++++ b/prog/check_funs.cpp
+@@ -647,7 +647,7 @@ static void print_truncate(FILE * out, const char * word, int width) {
+ }
+ }
+ if (i == width-1) {
+- if (word == '\0')
++ if (*word == '\0')
+ put(out,' ');
+ else if (word[len] == '\0')
+ put(out, word, len);