summaryrefslogtreecommitdiff
path: root/user/aspell
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-08-03 22:45:06 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-08-03 22:45:06 +0000
commitd51f0dda33290490df71836145be011d7e5c7ad4 (patch)
treea6fa51bdca8080a099f9d70e25b33e30895565f7 /user/aspell
parent3bf6c2f14c0cd6b736b5c74b3f48de16a81f74cc (diff)
downloadpackages-d51f0dda33290490df71836145be011d7e5c7ad4.tar.gz
packages-d51f0dda33290490df71836145be011d7e5c7ad4.tar.bz2
packages-d51f0dda33290490df71836145be011d7e5c7ad4.tar.xz
packages-d51f0dda33290490df71836145be011d7e5c7ad4.zip
user/aspell: unmaintained bump to 0.60.7 (Adopt me today)
Diffstat (limited to 'user/aspell')
-rw-r--r--user/aspell/APKBUILD16
-rw-r--r--user/aspell/aspell-0.60.6.1-gcc7-fixes.patch34
2 files changed, 4 insertions, 46 deletions
diff --git a/user/aspell/APKBUILD b/user/aspell/APKBUILD
index 88ab8a736..bce270974 100644
--- a/user/aspell/APKBUILD
+++ b/user/aspell/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer:
pkgname=aspell
-pkgver=0.60.6.1
-pkgrel=15
+pkgver=0.60.7
+pkgrel=0
pkgdesc="Libre spell checker software"
url="http://aspell.net/"
arch="all"
@@ -12,14 +12,7 @@ makedepends="ncurses-dev perl"
provides="aspell-utils"
subpackages="$pkgname-compat::noarch $pkgname-dev $pkgname-doc
$pkgname-lang"
-source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
- aspell-0.60.6.1-gcc7-fixes.patch
- "
-
-prepare() {
- default_prepare
- update_config_sub
-}
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
build() {
LIBS="-ltinfo" ./configure \
@@ -49,5 +42,4 @@ compat() {
mv spell ispell "$subpkgdir"/usr/bin/
}
-sha512sums="f310c7590be98406589b5c26ca36a2ecfe4733f0b40fd6c176b96b7955ef2b5cd0ec9a3d770cf132146ae7a896042b4b698945112995ee1ae66adcfa5542247f aspell-0.60.6.1.tar.gz
-7acdd483fa218952775282f42c28998b4901b1c70aeeef307835a205d1cde3fb2912898d08799ee596d744dde55d04e5c4905fb66d8bfa3028d1f5d45bb66d1e aspell-0.60.6.1-gcc7-fixes.patch"
+sha512sums="6f5fcd1c29164ee18f205594b66f382b51d19b17686293a931ca92c1442d3f7228627ca7d604d860551d0d367ac34dfb2ae34170a844f51e84e390fb1edc4535 aspell-0.60.7.tar.gz"
diff --git a/user/aspell/aspell-0.60.6.1-gcc7-fixes.patch b/user/aspell/aspell-0.60.6.1-gcc7-fixes.patch
deleted file mode 100644
index 4eb825a24..000000000
--- a/user/aspell/aspell-0.60.6.1-gcc7-fixes.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-commit 8089fa02122fed0a6394eba14bbedcb1d18e2384
-Author: Kevin Atkinson <kevina@gnu.org>
-Date: Thu Dec 29 00:50:31 2016 -0500
-
- Compile Fixes for GCC 7.
-
- Closes #519.
-
-diff --git a/modules/filter/tex.cpp b/modules/filter/tex.cpp
-index a979539..19ab63c 100644
---- a/modules/filter/tex.cpp
-+++ b/modules/filter/tex.cpp
-@@ -174,7 +174,7 @@ namespace {
-
- if (c == '{') {
-
-- if (top.in_what == Parm || top.in_what == Opt || top.do_check == '\0')
-+ if (top.in_what == Parm || top.in_what == Opt || *top.do_check == '\0')
- push_command(Parm);
-
- top.in_what = Parm;
-diff --git a/prog/check_funs.cpp b/prog/check_funs.cpp
-index db54f3d..89ee09d 100644
---- a/prog/check_funs.cpp
-+++ b/prog/check_funs.cpp
-@@ -647,7 +647,7 @@ static void print_truncate(FILE * out, const char * word, int width) {
- }
- }
- if (i == width-1) {
-- if (word == '\0')
-+ if (*word == '\0')
- put(out,' ');
- else if (word[len] == '\0')
- put(out, word, len);