summaryrefslogtreecommitdiff
path: root/user/atk
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-05 03:42:44 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-05 03:42:44 -0500
commitb489e79b4e160555482bee476faa88c261433cdc (patch)
tree9aae6260c1d1af309756bb166aefd0fec7de0557 /user/atk
parent5dd99a42c50db313e6f7dc469a41aa5990c29b4d (diff)
downloadpackages-b489e79b4e160555482bee476faa88c261433cdc.tar.gz
packages-b489e79b4e160555482bee476faa88c261433cdc.tar.bz2
packages-b489e79b4e160555482bee476faa88c261433cdc.tar.xz
packages-b489e79b4e160555482bee476faa88c261433cdc.zip
user/atk: pull in, fix
Diffstat (limited to 'user/atk')
-rw-r--r--user/atk/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/user/atk/APKBUILD b/user/atk/APKBUILD
new file mode 100644
index 000000000..b2232304b
--- /dev/null
+++ b/user/atk/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer:
+pkgname=atk
+pkgver=2.26.1
+pkgrel=3
+pkgdesc="A library providing a set of interfaces for accessibility"
+url="https://www.gtk.org/"
+arch="all"
+license="LGPL-2.0+"
+depends=""
+makedepends="glib-dev gobject-introspection-dev musl-utils"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --enable-introspection
+ make
+}
+
+check() {
+ cd "$builddir"/tests
+ # There is no test suite runner present, but the tests are built..
+ for testapp in testdocument testrelation testrole teststateset testvalue; do
+ ./$testapp
+ done
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="9a802f1856f0f608c3b4ef6de27dc8174e103dbb32431a4dcffcac48c685cc48efb087ab73f661d7327341e8074b73bb7877c596f93228283ca5907910d64a6b atk-2.26.1.tar.xz"