summaryrefslogtreecommitdiff
path: root/user/atk
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-09 23:44:04 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-09 23:44:04 -0500
commitcca145cde48970f0ac5f4d0f5847240ce48c1cff (patch)
tree819289dcc105f8da79a807d39bb782897318518c /user/atk
parent8eae39cb4d71fc79e88307a1bbf9fa4564908203 (diff)
downloadpackages-cca145cde48970f0ac5f4d0f5847240ce48c1cff.tar.gz
packages-cca145cde48970f0ac5f4d0f5847240ce48c1cff.tar.bz2
packages-cca145cde48970f0ac5f4d0f5847240ce48c1cff.tar.xz
packages-cca145cde48970f0ac5f4d0f5847240ce48c1cff.zip
user/atk: bump to 2.29.1, use meson
Diffstat (limited to 'user/atk')
-rw-r--r--user/atk/APKBUILD35
1 files changed, 17 insertions, 18 deletions
diff --git a/user/atk/APKBUILD b/user/atk/APKBUILD
index b2232304b..c548e5060 100644
--- a/user/atk/APKBUILD
+++ b/user/atk/APKBUILD
@@ -1,37 +1,36 @@
# Maintainer:
pkgname=atk
-pkgver=2.26.1
-pkgrel=3
+pkgver=2.29.1
+pkgrel=0
pkgdesc="A library providing a set of interfaces for accessibility"
url="https://www.gtk.org/"
arch="all"
license="LGPL-2.0+"
depends=""
-makedepends="glib-dev gobject-introspection-dev musl-utils"
+makedepends="glib-dev gobject-introspection-dev gtk-doc meson musl-utils ninja"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
-build() {
+prepare() {
cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --enable-introspection
- make
+ default_prepare
+ mkdir _build
+}
+
+build() {
+ cd "$builddir"/_build
+ meson -Dprefix=/usr -Dintrospection=true -Ddocs=true
+ ninja
}
check() {
- cd "$builddir"/tests
- # There is no test suite runner present, but the tests are built..
- for testapp in testdocument testrelation testrole teststateset testvalue; do
- ./$testapp
- done
+ cd "$builddir"/_build
+ ninja test
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ cd "$builddir"/_build
+ DESTDIR="$pkgdir" ninja install
}
-sha512sums="9a802f1856f0f608c3b4ef6de27dc8174e103dbb32431a4dcffcac48c685cc48efb087ab73f661d7327341e8074b73bb7877c596f93228283ca5907910d64a6b atk-2.26.1.tar.xz"
+sha512sums="833acad04bb5b224857025cc39a099c608d9c5b6f3dad52a770c6b8af502fc2ffcd1d4f5825fe7cf2134c8b7720f2a7f362e92604086020dccf22c29c3151e8c atk-2.29.1.tar.xz"