summaryrefslogtreecommitdiff
path: root/user/attica/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/attica/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/attica/APKBUILD')
-rw-r--r--user/attica/APKBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/user/attica/APKBUILD b/user/attica/APKBUILD
index c3a1bc8f6..7688326f4 100644
--- a/user/attica/APKBUILD
+++ b/user/attica/APKBUILD
@@ -1,22 +1,19 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=attica
-pkgver=5.54.0
+pkgver=5.68.0
pkgrel=0
pkgdesc="Qt 5-based implementation of Open Collaboration Services"
url="https://www.kde.org/"
arch="all"
license="LGPL-2.1-only"
depends=""
-depends_dev="qt5-qtbase-dev"
-makedepends="$depends_dev cmake extra-cmake-modules doxygen graphviz
+makedepends="cmake extra-cmake-modules doxygen graphviz qt5-qtbase-dev
qt5-qttools-dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/attica-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -28,18 +25,16 @@ build() {
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DBUILD_QCH:BOOL=ON \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="f278423e5bcbd1899d6c41caceee740e3caee01dd1af20303827ec5a807e262e560b068dcb6619f5410ebe815b71b1244ccc453c49956c3bfd1452a88ecf5b18 attica-5.54.0.tar.xz"
+sha512sums="225bec1c0e54ce1c13273aeb8ea2350c15f147c0d68c6a4427b5da381f72dfb5817eabb5f2a798cece49d14b111ca205b21576222ed8eeb8000b7fa760a1d30d attica-5.68.0.tar.xz"