summaryrefslogtreecommitdiff
path: root/user/bsdwhois/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-09-17 01:45:21 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-09-17 01:45:21 +0000
commit9e696c7e0be62f73bfbc3d97ba66e7d0bdc46b6b (patch)
tree793f05dd03c5d4e9501afb34c148c3cd8a171b2b /user/bsdwhois/APKBUILD
parent83ec5ee26089ea7dfe0a04402e92561c42599c5b (diff)
downloadpackages-9e696c7e0be62f73bfbc3d97ba66e7d0bdc46b6b.tar.gz
packages-9e696c7e0be62f73bfbc3d97ba66e7d0bdc46b6b.tar.bz2
packages-9e696c7e0be62f73bfbc3d97ba66e7d0bdc46b6b.tar.xz
packages-9e696c7e0be62f73bfbc3d97ba66e7d0bdc46b6b.zip
user/bsdwhois: new package
Diffstat (limited to 'user/bsdwhois/APKBUILD')
-rw-r--r--user/bsdwhois/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/user/bsdwhois/APKBUILD b/user/bsdwhois/APKBUILD
new file mode 100644
index 000000000..d5222238d
--- /dev/null
+++ b/user/bsdwhois/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=bsdwhois
+pkgver=1.43.2.1
+pkgrel=0
+pkgdesc="WHOIS client, allowing you to see details about domain names and IP subnets"
+url="https://www.FreeBSD.org/"
+arch="all"
+options="!check" # No test suite.
+license="BSD-4-Clause-UC"
+depends=""
+makedepends="bsd-compat-headers"
+subpackages="$pkgname-doc"
+source="http://utenti.gufi.org/~drizzt/codes/bsdwhois-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+
+ install -D -m755 "$builddir"/whois "$pkgdir"/usr/bin/whois
+ install -D -m644 "$builddir"/whois.1 "$pkgdir"/usr/share/man/man1/whois.1
+}
+
+sha512sums="a69f9768a500ce08daa6cc0105c4d6591e4d33b570fa323166b06286b70ae7cc49cd1f77d04a411f558ea55c43316ffdbe897eb3c83ae331e2e4d9800a8a29d3 bsdwhois-1.43.2.1.tar.bz2"