summaryrefslogtreecommitdiff
path: root/user/cantarell-fonts
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-10 17:54:49 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-10 17:54:49 +0000
commit45e0f43f4613641ef3f9e15de696567037d5da2a (patch)
tree354baa9615d211b17731dcea9ea5e34e8ba2a498 /user/cantarell-fonts
parente3d0a05d8fc328b9d57cf0d2acb1dfd42d258be8 (diff)
downloadpackages-45e0f43f4613641ef3f9e15de696567037d5da2a.tar.gz
packages-45e0f43f4613641ef3f9e15de696567037d5da2a.tar.bz2
packages-45e0f43f4613641ef3f9e15de696567037d5da2a.tar.xz
packages-45e0f43f4613641ef3f9e15de696567037d5da2a.zip
user/cantarell-fonts: new package
Diffstat (limited to 'user/cantarell-fonts')
-rw-r--r--user/cantarell-fonts/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/user/cantarell-fonts/APKBUILD b/user/cantarell-fonts/APKBUILD
new file mode 100644
index 000000000..1d0aa9876
--- /dev/null
+++ b/user/cantarell-fonts/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=cantarell-fonts
+pkgver=0.111
+pkgrel=0
+pkgdesc="Humanist sans-serif typeface from GNOME"
+url=" "
+arch="noarch"
+options="!check" # Impossible to test font
+license="OFL-1.1"
+depends="fontconfig mkfontdir"
+makedepends=""
+subpackages=""
+replaces="ttf-cantarell"
+source="https://download.gnome.org/sources/cantarell-fonts/$pkgver/cantarell-fonts-$pkgver.tar.xz"
+
+package() {
+ local _otf
+ cd "$builddir"/prebuilt
+ mkdir -p "$pkgdir"/usr/share/fonts/$pkgname
+ for _otf in *.otf; do
+ install -m644 "$_otf" "$pkgdir"/usr/share/fonts/$pkgname/$_otf
+ done
+}
+
+sha512sums="638298a6381a3ede862d1b100fcfea943bebb5e1c0dc4f1597ab2f841e933b484436b139090a669c770c02483a24f2b92bbd12bce71d7a40eb4c325573e3df9e cantarell-fonts-0.111.tar.xz"