summaryrefslogtreecommitdiff
path: root/user/cantor/rip-out-webengine.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-06-12 04:23:28 -0500
committerZach van Rijn <me@zv.io>2022-10-21 18:34:01 -0500
commit229100ecde79f6f3d031eb618acccb5aa6195b22 (patch)
treef97440428c3a2112044ff8814cf03cb7002a117a /user/cantor/rip-out-webengine.patch
parentb05ce5add8948fa72697935d192aa78b5205cce4 (diff)
downloadpackages-229100ecde79f6f3d031eb618acccb5aa6195b22.tar.gz
packages-229100ecde79f6f3d031eb618acccb5aa6195b22.tar.bz2
packages-229100ecde79f6f3d031eb618acccb5aa6195b22.tar.xz
packages-229100ecde79f6f3d031eb618acccb5aa6195b22.zip
user/[KDE Apps]: Update to 22.04.2
Diffstat (limited to 'user/cantor/rip-out-webengine.patch')
-rw-r--r--user/cantor/rip-out-webengine.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/user/cantor/rip-out-webengine.patch b/user/cantor/rip-out-webengine.patch
new file mode 100644
index 000000000..15bda36b1
--- /dev/null
+++ b/user/cantor/rip-out-webengine.patch
@@ -0,0 +1,56 @@
+This is temporary until I have time to write a proper patch to make the
+WebEngine dependency truly optional.
+
+Upstream-URL: https://bugs.kde.org/show_bug.cgi?id=455108
+BUG: 455108
+
+--- cantor-22.04.2/CMakeLists.txt.old 2022-06-06 22:43:15.000000000 -0500
++++ cantor-22.04.2/CMakeLists.txt 2022-06-10 00:48:15.475027350 -0500
+@@ -37,9 +37,7 @@
+ Xml
+ XmlPatterns
+ Test
+- Help
+- WebEngine
+- WebEngineWidgets)
++ Help)
+
+ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED
+ Config
+--- cantor-22.04.2/src/CMakeLists.txt.old 2022-06-06 22:43:15.000000000 -0500
++++ cantor-22.04.2/src/CMakeLists.txt 2022-06-10 00:47:38.599064429 -0500
+@@ -39,7 +39,7 @@
+ add_executable(cantor ${cantor_SRCS})
+
+ target_link_libraries(cantor KF5::Parts KF5::NewStuff KF5::ConfigCore KF5::CoreAddons KF5::ConfigGui
+- KF5::Crash KF5::XmlGui Qt5::WebEngine cantorlibs cantor_config)
++ KF5::Crash KF5::XmlGui cantorlibs cantor_config)
+
+ ########### install files ###############
+ install(TARGETS cantor ${KDE_INSTALL_TARGETS_DEFAULT_ARGS} )
+--- cantor-22.04.2/src/panelplugins/CMakeLists.txt.old 2022-06-06 22:43:15.000000000 -0500
++++ cantor-22.04.2/src/panelplugins/CMakeLists.txt 2022-06-10 00:46:15.718138007 -0500
+@@ -13,4 +13,3 @@
+ add_subdirectory(variablemgr)
+ add_subdirectory(filebrowserpanel)
+ add_subdirectory(tocpanel)
+-add_subdirectory(documentationpanel)
+--- cantor-22.04.2/src/main.cpp.old 2022-06-06 22:43:15.000000000 -0500
++++ cantor-22.04.2/src/main.cpp 2022-06-10 00:46:37.755725391 -0500
+@@ -17,16 +17,10 @@
+ #include <QFileInfo>
+ #include <QDir>
+ #include <QDebug>
+-#include <QtWebEngine>
+
+
+ int main(int argc, char **argv)
+ {
+- QtWebEngine::initialize();
+- // Register custom scheme handler for qthelp:// scheme
+- QWebEngineUrlScheme qthelp("qthelp");
+- QWebEngineUrlScheme::registerScheme(qthelp);
+-
+ QApplication::setAttribute(Qt::AA_EnableHighDpiScaling);
+ QApplication app(argc, argv);
+