summaryrefslogtreecommitdiff
path: root/user/chrpath
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-04 20:31:16 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-04 20:31:16 -0500
commitaedac9efe354d3ec7c57b5761c37f27089a55dfd (patch)
treecc86b19b52b1ff21e939cfd9f0053d1840e4177b /user/chrpath
parentbd7707c967f67f6e9a523fae5464f0d121db4f10 (diff)
downloadpackages-aedac9efe354d3ec7c57b5761c37f27089a55dfd.tar.gz
packages-aedac9efe354d3ec7c57b5761c37f27089a55dfd.tar.bz2
packages-aedac9efe354d3ec7c57b5761c37f27089a55dfd.tar.xz
packages-aedac9efe354d3ec7c57b5761c37f27089a55dfd.zip
user/chrpath: fix all the metadata, like, ALL the metadata
Diffstat (limited to 'user/chrpath')
-rw-r--r--user/chrpath/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/user/chrpath/APKBUILD b/user/chrpath/APKBUILD
new file mode 100644
index 000000000..869a8bfdd
--- /dev/null
+++ b/user/chrpath/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Dead Upstream <nobody@deprecated.invalid>
+pkgname=chrpath
+pkgver=0.16
+pkgrel=2
+pkgdesc="Modify rpath of compiled programs"
+url="https://github.com/jwilk-mirrors/chrpath"
+arch="all"
+license="GPL-2.0-only"
+subpackages="$pkgname-doc"
+source="https://alioth-archive.debian.org/releases/chrpath/chrpath/0.16/chrpath-0.16.tar.gz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" docdir=/usr/share/doc/$pkgname-$pkgver \
+ install
+}
+
+sha512sums="aa04d490f78bff20a56fe20539cec10218c0772a668909eda8324ca825f51e8ef92001e95d9c316e79a145a043c9c327ec94d1a82e104ab408ca1021832745aa chrpath-0.16.tar.gz"