summaryrefslogtreecommitdiff
path: root/user/clang
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-09-18 02:10:11 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-09-18 02:10:11 +0000
commit7644495470430e473b2fcf2116919cee7b91512f (patch)
tree8cce6bd4b5073b8c926c3acc24f4973ce018894d /user/clang
parent3eef3c84f5d830f3621d5326577f25bb925abca6 (diff)
downloadpackages-7644495470430e473b2fcf2116919cee7b91512f.tar.gz
packages-7644495470430e473b2fcf2116919cee7b91512f.tar.bz2
packages-7644495470430e473b2fcf2116919cee7b91512f.tar.xz
packages-7644495470430e473b2fcf2116919cee7b91512f.zip
user/clang: strip debug info, only add symlink when needed
Diffstat (limited to 'user/clang')
-rw-r--r--user/clang/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/user/clang/APKBUILD b/user/clang/APKBUILD
index 8bcb9c2dd..826ca3373 100644
--- a/user/clang/APKBUILD
+++ b/user/clang/APKBUILD
@@ -50,7 +50,7 @@ build() {
check() {
cd "$builddir"/build
- ln -s /usr/bin/lit bin/llvm-lit
+ [ -f bin/llvm-lit ] || ln -s /usr/bin/lit bin/llvm-lit
make check-clang
}
@@ -66,6 +66,7 @@ static() {
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib/
+ strip -d "$subpkgdir"/usr/lib/*.a
}
analyzer() {