summaryrefslogtreecommitdiff
path: root/user/command-not-found/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 10:35:07 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-12 10:35:07 +0000
commit20b49018c40a8128596be4450639bb4252be6e15 (patch)
treead628ac854a36c5979d83df0be7aaffbfde6339d /user/command-not-found/APKBUILD
parent60669ea0bb74adb5892714a8580e984eb446fb53 (diff)
downloadpackages-20b49018c40a8128596be4450639bb4252be6e15.tar.gz
packages-20b49018c40a8128596be4450639bb4252be6e15.tar.bz2
packages-20b49018c40a8128596be4450639bb4252be6e15.tar.xz
packages-20b49018c40a8128596be4450639bb4252be6e15.zip
user/*: Modernise / fix syntax / deps / metadata
Diffstat (limited to 'user/command-not-found/APKBUILD')
-rw-r--r--user/command-not-found/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/user/command-not-found/APKBUILD b/user/command-not-found/APKBUILD
index 96cd1127d..ed9919343 100644
--- a/user/command-not-found/APKBUILD
+++ b/user/command-not-found/APKBUILD
@@ -11,13 +11,12 @@ license="MIT"
depends="apk-tools"
makedepends=""
subpackages="$pkgname-bash $pkgname-zsh"
-source="$pkgname-$pkgver.tar.gz::https://git.dereferenced.org/kaniini/command-not-found/archive/v$pkgver.tar.gz
+source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.gz
explicit-apk-path.patch
"
builddir="$srcdir/$pkgname"
package() {
- cd "$builddir"
install -d -D -m755 "$pkgdir"/usr/libexec
install -m755 command-not-found.sh "$pkgdir"/usr/libexec/command-not-found
}
@@ -25,17 +24,15 @@ package() {
bash() {
pkgdesc="$pkgdesc (Bash shell support)"
install_if="$pkgname=$pkgver-r$pkgrel bash"
- cd "$builddir"
install -d -D -m755 "$subpkgdir"/etc/profile.d/
- install -m755 profiles/command-not-found.ash "$subpkgdir"/etc/profile.d/command-not-found.sh
+ install -m755 "$builddir"/profiles/command-not-found.ash "$subpkgdir"/etc/profile.d/command-not-found.sh
}
zsh() {
pkgdesc="$pkgdesc (Z shell support)"
install_if="$pkgname=$pkgver-r$pkgrel zsh"
- cd "$builddir"
install -d -D -m755 "$subpkgdir"/etc/zprofile.d/
- install -m755 profiles/command-not-found.zsh "$subpkgdir"/etc/zprofile.d/command-not-found.zsh
+ install -m755 "$builddir"/profiles/command-not-found.zsh "$subpkgdir"/etc/zprofile.d/command-not-found.zsh
}
sha512sums="a9fc6cf063195abf4bbf015f770b93fb23e2afc0efbed10a54adc1e0d38d7f9a57ab5817a52e483dd01aa21888e76f5aaefdbf89c835f227be2f150848ddb7ad command-not-found-0.3.tar.gz