summaryrefslogtreecommitdiff
path: root/user/compton
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-13 05:05:43 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-13 05:05:43 +0000
commitf809d27d00677997adac74dc1422d8a42ec69b0c (patch)
treeaf404a9ba09eac3ec534a308260193454781879e /user/compton
parent025606accdfe07de9aafe079e4f068ac4d54d9d1 (diff)
downloadpackages-f809d27d00677997adac74dc1422d8a42ec69b0c.tar.gz
packages-f809d27d00677997adac74dc1422d8a42ec69b0c.tar.bz2
packages-f809d27d00677997adac74dc1422d8a42ec69b0c.tar.xz
packages-f809d27d00677997adac74dc1422d8a42ec69b0c.zip
user/*: Modernise / fix syntax / deps / metadata / code
Diffstat (limited to 'user/compton')
-rw-r--r--user/compton/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/user/compton/APKBUILD b/user/compton/APKBUILD
index 0cfae4b52..82b9cc638 100644
--- a/user/compton/APKBUILD
+++ b/user/compton/APKBUILD
@@ -6,15 +6,15 @@ pkgrel=0
pkgdesc="Lightweight compositor for X11"
url="https://github.com/yshui/compton"
arch="all"
-options="!check" # no tests
+options="!check" # No test suite.
license="MIT AND MPL-2.0"
+depends=""
makedepends="meson libx11-dev libxext-dev libev-dev xcb-util-renderutil-dev
xcb-util-image-dev pixman-dev libconfig-dev pcre-dev mesa-dev
dbus-dev"
-source="compton-$pkgver.tar.gz::https://github.com/yshui/compton/archive/v$pkgver.tar.gz"
+source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.gz"
build() {
- cd "$builddir"
meson \
--prefix=/usr \
--sysconfdir=/etc \
@@ -26,7 +26,6 @@ build() {
}
package() {
- cd "$builddir"
DESTDIR="$pkgdir" ninja -C output install
}