summaryrefslogtreecommitdiff
path: root/user/cunit
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-02-01 17:38:09 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:33:57 -0500
commit1601429468973e49ae3eb83496ae9e221fca9a8c (patch)
tree9a16664f327080f7c1ce03a500c3499e8ba18f5d /user/cunit
parent2f74a75d153cd7786af6c68f88faaad181464e3e (diff)
downloadpackages-1601429468973e49ae3eb83496ae9e221fca9a8c.tar.gz
packages-1601429468973e49ae3eb83496ae9e221fca9a8c.tar.bz2
packages-1601429468973e49ae3eb83496ae9e221fca9a8c.tar.xz
packages-1601429468973e49ae3eb83496ae9e221fca9a8c.zip
user/cunit: new package.
Diffstat (limited to 'user/cunit')
-rw-r--r--user/cunit/APKBUILD51
-rw-r--r--user/cunit/path-makefile.patch31
2 files changed, 82 insertions, 0 deletions
diff --git a/user/cunit/APKBUILD b/user/cunit/APKBUILD
new file mode 100644
index 000000000..d9b755065
--- /dev/null
+++ b/user/cunit/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=cunit
+_pkgname=CUnit
+pkgver=2.1.3
+_pkgver=${pkgver%.*}-${pkgver##*.}
+pkgrel=0
+pkgdesc="Automated testing framework for C"
+url="http://cunit.sourceforge.net/"
+arch="all"
+license="LGPL-2.0+"
+depends=""
+makedepends="automake autoconf libtool bash"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://downloads.sourceforge.net/project/$pkgname/$_pkgname/$_pkgver/$_pkgname-$_pkgver.tar.bz2
+ path-makefile.patch
+ "
+builddir="$srcdir/$_pkgname-$_pkgver"
+
+prepare() {
+ default_prepare
+ ./bootstrap
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --includedir=/usr/include \
+ --datarootdir=/usr/share \
+ --libdir=/usr/lib \
+ --enable-debug \
+ --enable-examples \
+ --enable-automated \
+ --enable-basic \
+ --enable-test \
+ --disable-static
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="547b417109332446dfab8fda17bf4ccd2da841dc93f824dc90a20635bcf1fb80fb2176500d8a0906940f3f3d3e2f77b2d70a71090c9ab84ad9af43f3582bc487 CUnit-2.1-3.tar.bz2
+1a4e670c8eeb1b2b19c079cdb2d025a688c76e8eba19ff54a4737d9cf18c22656fe83af2c728111ceb5740601bf48edf9d1537397369c4c3c78397849361169f path-makefile.patch"
diff --git a/user/cunit/path-makefile.patch b/user/cunit/path-makefile.patch
new file mode 100644
index 000000000..0e16aaa25
--- /dev/null
+++ b/user/cunit/path-makefile.patch
@@ -0,0 +1,31 @@
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index a864d46..1c15fc0 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-docdir = $(prefix)/doc/@PACKAGE@
++docdir = $(datarootdir)/doc/@PACKAGE@
+
+ doc_DATA = \
+ CUnit_doc.css \
+@@ -13,4 +13,4 @@ doc_DATA = \
+ test_registry.html \
+ writing_tests.html
+
+-SUBDIRS = headers
+\ No newline at end of file
++SUBDIRS = headers
+diff --git a/doc/headers/Makefile.am b/doc/headers/Makefile.am
+index 9926e8b..3c5f1ba 100644
+--- a/doc/headers/Makefile.am
++++ b/doc/headers/Makefile.am
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-dochdrdir = $(prefix)/doc/@PACKAGE@/headers
++dochdrdir = $(datarootdir)/doc/@PACKAGE@/headers
+
+ INCLUDE_FILES = \
+ Automated.h \