summaryrefslogtreecommitdiff
path: root/user/dconf
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-06 00:36:14 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-06 00:36:14 +0000
commitad24c013617b1481d0830fafd0555f6a02cd199f (patch)
treec0488c5fe6af6b16b0970ec608e7556f2d12d42e /user/dconf
parent2d02fd2cbaddbbfb4a5062d4f21b2690ac93ff47 (diff)
downloadpackages-ad24c013617b1481d0830fafd0555f6a02cd199f.tar.gz
packages-ad24c013617b1481d0830fafd0555f6a02cd199f.tar.bz2
packages-ad24c013617b1481d0830fafd0555f6a02cd199f.tar.xz
packages-ad24c013617b1481d0830fafd0555f6a02cd199f.zip
user/dconf: Fix build against Meson 0.52+
Diffstat (limited to 'user/dconf')
-rw-r--r--user/dconf/APKBUILD7
-rw-r--r--user/dconf/meson.patch35
2 files changed, 40 insertions, 2 deletions
diff --git a/user/dconf/APKBUILD b/user/dconf/APKBUILD
index cb5843f8f..3495c4f93 100644
--- a/user/dconf/APKBUILD
+++ b/user/dconf/APKBUILD
@@ -12,7 +12,9 @@ depends="dbus"
makedepends="meson ninja
bash-completion dbus-dev docbook-xsl libxslt-dev python3-dev vala-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://download.gnome.org/sources/dconf/${pkgver%.*}/dconf-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/dconf/${pkgver%.*}/dconf-$pkgver.tar.xz
+ meson.patch
+ "
build() {
meson \
@@ -30,4 +32,5 @@ package() {
DESTDIR="$pkgdir" ninja -C build install
}
-sha512sums="8b28373f31fe36ba3f21f56fca84563681c3648ff595709880cd9ac49fc6b130ac375fb89fd585f1dd62b5a2f728127292ea57d18feca1147b709a93e8c4c743 dconf-0.34.0.tar.xz"
+sha512sums="8b28373f31fe36ba3f21f56fca84563681c3648ff595709880cd9ac49fc6b130ac375fb89fd585f1dd62b5a2f728127292ea57d18feca1147b709a93e8c4c743 dconf-0.34.0.tar.xz
+be807b17c20c829b307da2df23252893f99f47845825328a0b1880aad9d97f85fe1d66be3903e8c1cc62bb6daa2baf1462bc09daf397c31394e7159ede07d58c meson.patch"
diff --git a/user/dconf/meson.patch b/user/dconf/meson.patch
new file mode 100644
index 000000000..77d980e31
--- /dev/null
+++ b/user/dconf/meson.patch
@@ -0,0 +1,35 @@
+From cc32667c5d7d9ff95e65cc21f59905d8f9218394 Mon Sep 17 00:00:00 2001
+From: Diego Escalante Urrelo <diegoe@gnome.org>
+Date: Thu, 31 Oct 2019 05:51:22 -0500
+Subject: [PATCH] build: Update use of link_whole for meson-0.52
+
+A regression in meson-0.52 caused uses of link_whole to expose scenarios
+where duplicate symbols issues could appear. In particular
+libdconf_client_dep was being link_whole'd to itself, which recursively
+already included libdconf_common which was also a link_whole.
+
+This change does not modify the available symbols in libdconf.so, and is
+compatible with meson-0.52 and 0.51.
+
+See: https://github.com/mesonbuild/meson/pull/6030
+Fixes: https://gitlab.gnome.org/GNOME/dconf/issues/59
+---
+ client/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/client/meson.build b/client/meson.build
+index f3b7122..de6387e 100644
+--- a/client/meson.build
++++ b/client/meson.build
+@@ -28,7 +28,7 @@ libdconf_client = static_library(
+
+ libdconf_client_dep = declare_dependency(
+ dependencies: gio_dep,
+- link_whole: libdconf_client,
++ link_with: libdconf_client,
+ )
+
+ libdconf = shared_library(
+--
+2.24.1
+