summaryrefslogtreecommitdiff
path: root/user/dev86
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-03-19 16:57:19 -0500
committerMax Rees <maxcrees@me.com>2020-03-19 16:57:19 -0500
commit2fb8c4c10e502f48a4ccb653917e6ee99d81c5b1 (patch)
tree92858b6edb7fbf4f8c4395f1312b0562a96b2811 /user/dev86
parent3e7d2c3bb270b56c4b30a5e580146c7a87cd9bf4 (diff)
downloadpackages-2fb8c4c10e502f48a4ccb653917e6ee99d81c5b1.tar.gz
packages-2fb8c4c10e502f48a4ccb653917e6ee99d81c5b1.tar.bz2
packages-2fb8c4c10e502f48a4ccb653917e6ee99d81c5b1.tar.xz
packages-2fb8c4c10e502f48a4ccb653917e6ee99d81c5b1.zip
user/dev86: new package
Diffstat (limited to 'user/dev86')
-rw-r--r--user/dev86/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/user/dev86/APKBUILD b/user/dev86/APKBUILD
new file mode 100644
index 000000000..a17deec0f
--- /dev/null
+++ b/user/dev86/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=dev86
+pkgver=0.16.21
+pkgrel=0
+pkgdesc="Standalone 8086 assembler and linker"
+url="https://github.com/lkundrak/dev86/"
+arch="pmmx x86 x86_64"
+options="!check" # Just compiles stuff with bcc which we don't build
+license="GPL-2.0 AND LGPL-2.0"
+depends=""
+makedepends=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/lkundrak/dev86/archive/v$pkgver.tar.gz"
+
+build() {
+ make -j1 as ld \
+ GCCFLAG="$CFLAGS" \
+ NATIVE='-DA_OUT_INCL=\"../libc/include/a.out.h\"'
+}
+
+package() {
+ install -Dm755 as/as86 "$pkgdir"/usr/bin/as86
+ install -Dm755 ld/ld86 "$pkgdir"/usr/bin/ld86
+
+ install -Dm644 man/as86.1 "$pkgdir"/usr/share/man/man1/as86.1
+ install -Dm644 man/ld86.1 "$pkgdir"/usr/share/man/man1/ld86.1
+}
+
+sha512sums="e51d94cecc298f860c1dcbc225d5c77a18769eb7a51f888853ca3bdb3cc6596c07d67cd9b403f7d52155716eb1708396461dc596cd02728d762d0ed5e87d054f dev86-0.16.21.tar.gz"