summaryrefslogtreecommitdiff
path: root/user/dumb-init
diff options
context:
space:
mode:
authorAlyx <alyx@malkier.net>2019-07-24 19:15:57 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-07-24 19:15:57 +0000
commit8750fcce82ffa842dd01a08826c5373162ed1674 (patch)
tree933ab6169225a820e48c6dd9ccae660657d18ee5 /user/dumb-init
parentbed7a51ed2c79f05cb1cf4708d4e128cfb23133a (diff)
downloadpackages-8750fcce82ffa842dd01a08826c5373162ed1674.tar.gz
packages-8750fcce82ffa842dd01a08826c5373162ed1674.tar.bz2
packages-8750fcce82ffa842dd01a08826c5373162ed1674.tar.xz
packages-8750fcce82ffa842dd01a08826c5373162ed1674.zip
user/dumb-init: new package. An init, but dumb
Diffstat (limited to 'user/dumb-init')
-rw-r--r--user/dumb-init/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/user/dumb-init/APKBUILD b/user/dumb-init/APKBUILD
new file mode 100644
index 000000000..e500cb008
--- /dev/null
+++ b/user/dumb-init/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Alyx Wolcott <alyx@leuhta.com>
+# Maintainer: Alyx Wolcott <alyx@leuhta.com>
+pkgname=dumb-init
+pkgver=1.2.2
+pkgrel=0
+pkgdesc="A minimal init system for Linux containers"
+url="https://github.com/Yelp/dumb-init"
+arch="all"
+options="!check" # Check requires Python 3.7 and will not function correctly within chroots.
+license="MIT"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Yelp/$pkgname/archive/v$pkgver.tar.gz"
+
+build() {
+ make
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ install -m755 ./dumb-init $pkgdir/usr/bin/
+}
+
+sha512sums="efb0b99d3a98a2ff0bd1ac9d105f034589869b44237575489fb0d2ebb99b13df4451cf355bf285b91ac1e87af9d5ac87aed3e9d225f0c0f47299ca716ed70b27 dumb-init-1.2.2.tar.gz"