summaryrefslogtreecommitdiff
path: root/user/enchant
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-06 06:30:27 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-06 17:56:35 -0500
commit99dc7131c241bd1550250db109bd874bd9e899e5 (patch)
treee91fc8e669e9aa310b8da1d804705c39bfc0f88b /user/enchant
parent97916d382fdfd1014c3f930d222a1fdc4369b101 (diff)
downloadpackages-99dc7131c241bd1550250db109bd874bd9e899e5.tar.gz
packages-99dc7131c241bd1550250db109bd874bd9e899e5.tar.bz2
packages-99dc7131c241bd1550250db109bd874bd9e899e5.tar.xz
packages-99dc7131c241bd1550250db109bd874bd9e899e5.zip
user/enchant: see, Elizafox? Obj-C is important
Diffstat (limited to 'user/enchant')
-rw-r--r--user/enchant/APKBUILD37
-rw-r--r--user/enchant/hunspell-build-fix.patch14
2 files changed, 51 insertions, 0 deletions
diff --git a/user/enchant/APKBUILD b/user/enchant/APKBUILD
new file mode 100644
index 000000000..208b90171
--- /dev/null
+++ b/user/enchant/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=enchant
+pkgver=1.6.1
+pkgrel=0
+pkgdesc="A wrapper library for generic spell checking"
+url="https://abiword.github.io/enchant/"
+arch="all"
+options="!check" # We need to ship dictionaries before testing will work...
+license="LGPL-2.0+"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=""
+makedepends="aspell-dev bash file glib-dev dbus-glib-dev hunspell-dev"
+source="https://github.com/AbiWord/enchant/releases/download/enchant-1-6-1/enchant-1.6.1.tar.gz
+ hunspell-build-fix.patch"
+
+build() {
+ cd "$builddir"
+ CC="gcc" OBJC="gcc" ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="26c62dfa89ee40150db502651a2f876fba00569b7015f205dae27a029557effacff335bbe36124dbe6686537da2305bcab02592179d03e95fdf9741d54b98036 enchant-1.6.1.tar.gz
+c0b7fd8fd00a81ea2c08ea7ce2bdffa826b5a3a0c06eacb818681f0f977d8e76c69f7938c10cdf71571cd1cbbf0e576d36fc74a41755fb570e047525195aeb99 hunspell-build-fix.patch"
diff --git a/user/enchant/hunspell-build-fix.patch b/user/enchant/hunspell-build-fix.patch
new file mode 100644
index 000000000..0ecdb24b3
--- /dev/null
+++ b/user/enchant/hunspell-build-fix.patch
@@ -0,0 +1,14 @@
+diff -ru enchant-1.6.0-orig/src/myspell/myspell_checker.cpp enchant-1.6.0/src/myspell/myspell_checker.cpp
+--- enchant-1.6.0-orig/src/myspell/myspell_checker.cpp 2016-04-18 12:25:00.094614256 +0100
++++ enchant-1.6.0/src/myspell/myspell_checker.cpp 2016-04-18 12:26:09.108569576 +0100
+@@ -148,6 +148,10 @@
+ g_iconv_close(m_translate_out);
+ }
+
++#ifndef MAXWORDLEN
++# define MAXWORDLEN 100
++#endif
++
+ bool
+ MySpellChecker::checkWord(const char *utf8Word, size_t len)
+ {