summaryrefslogtreecommitdiff
path: root/user/feh
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-03-24 04:18:42 +0000
committerMax Rees <maxcrees@me.com>2018-03-24 04:25:53 +0000
commitf58cddd786b78f6adc2d484ef89efba5589a4b02 (patch)
tree66026ee17f2ee066575ad8737a8261515279a69f /user/feh
parent5eb51d5c02acc9bbcd26c5c9dbfb8b8831b662ae (diff)
downloadpackages-f58cddd786b78f6adc2d484ef89efba5589a4b02.tar.gz
packages-f58cddd786b78f6adc2d484ef89efba5589a4b02.tar.bz2
packages-f58cddd786b78f6adc2d484ef89efba5589a4b02.tar.xz
packages-f58cddd786b78f6adc2d484ef89efba5589a4b02.zip
user/feh: bump to 2.25.1
Diffstat (limited to 'user/feh')
-rw-r--r--user/feh/APKBUILD10
-rw-r--r--user/feh/cflags.patch11
-rw-r--r--user/feh/stdout-buff.patch113
3 files changed, 3 insertions, 131 deletions
diff --git a/user/feh/APKBUILD b/user/feh/APKBUILD
index b68566ae2..1ea78d33e 100644
--- a/user/feh/APKBUILD
+++ b/user/feh/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Max Rees <maxcrees@me.com>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=feh
-pkgver=2.23
+pkgver=2.25.1
pkgrel=0
pkgdesc="feh is a fast, lightweight image viewer which uses imlib2"
url="http://feh.finalrewind.org/"
@@ -12,9 +12,7 @@ depends=
makedepends="libxt-dev libpng-dev giblib-dev imlib2-dev libjpeg-turbo-dev
libxinerama-dev curl-dev libexif-dev"
checkdepends="perl-utils perl-test-command"
-source="https://feh.finalrewind.org/$pkgname-$pkgver.tar.bz2
- stdout-buff.patch
- cflags.patch"
+source="https://feh.finalrewind.org/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -37,6 +35,4 @@ package() {
install
}
-sha512sums="4b75f0053c3a4b1fb51251536896fd48470117ca3d59de1ac5a87f8071f37f886542e7d82730eec4579a1ebf507e4bc8a00fc45cf1364d2445b1aa82c5664ee7 feh-2.23.tar.bz2
-38ead15a58c402181da3e39c09002d9f951b03cfdf5edde19072da313638025dca5fa7dbe466b8f05094d49d44750c467d7fa3832fbaa11ac135c5839e0ecdc1 stdout-buff.patch
-577e0420aef6bbf1cc43fe97813fd56a877c45b9cb01f1f86ee41863a8bf12f97b5f62c01b37a6b8fc78f7dd8ab9a372d1b09ba00e3811d0043772f5e16e0707 cflags.patch"
+sha512sums="a821d46901d4cf59bb09b911f28c6ab26fbd0ee9784b50fbacfb6cf23483da5d29ebbb4cc53b23289181bb3ba0dc9893a3f39a90b3420d0bd98d740d5583fc3e feh-2.25.1.tar.bz2"
diff --git a/user/feh/cflags.patch b/user/feh/cflags.patch
deleted file mode 100644
index 88f0c05c9..000000000
--- a/user/feh/cflags.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- feh-2.23/config.mk 2017-12-28 18:28:35.000000000 +0000
-+++ feh-2.23/config.mk 2018-01-08 01:19:54.440000000 +0000
-@@ -38,7 +38,7 @@
- CFLAGS += -Wall -Wextra -pedantic
-
- # Settings for glibc >= 2.19 - may need to be adjusted for other systems
--CFLAGS += -std=c11 -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=500
-+CFLAGS += -std=c11 -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700
-
- ifeq (${curl},1)
- CFLAGS += -DHAVE_LIBCURL
diff --git a/user/feh/stdout-buff.patch b/user/feh/stdout-buff.patch
deleted file mode 100644
index eaa251a3a..000000000
--- a/user/feh/stdout-buff.patch
+++ /dev/null
@@ -1,113 +0,0 @@
-On glibc, if output is redirected to a file, output will look like this:
-
-touch test/ok/gif
-touch test/ok/jpg
-touch test/ok/png
-touch test/ok/pnm
-test/ok/gif
-test/ok/jpg
-test/ok/png
-test/ok/pnm
-
-On musl, if stdout is redirected to a file, output looks like this:
-
-test/ok/gif
-touch test/ok/gif
-touch test/ok/jpg
-touch test/ok/png
-touch test/ok/pnm
-test/ok/jpg
-test/ok/png
-test/ok/pnm
-
-On glibc and musl, if stdout is interactive, it looks like this:
-
-test/ok/gif
-touch test/ok/gif
-test/ok/jpg
-touch test/ok/jpg
-test/ok/png
-touch test/ok/png
-test/ok/pnm
-touch test/ok/pnm
-
-Adding two fflush calls makes all behavior look like the last example.
-
---- feh-2.22/src/list.c 2017-11-04 14:03:43.000000000 +0000
-+++ feh-2.22/src/list.c 2018-01-03 02:59:08.840000000 +0000
-@@ -92,6 +92,7 @@
- if (opt.verbose)
- feh_display_status('.');
- puts(file->filename);
-+ fflush(stdout);
- feh_action_run(file, opt.actions[0], NULL);
- }
- else {
-@@ -106,6 +107,7 @@
- if (opt.verbose)
- feh_display_status('.');
- puts(file->filename);
-+ fflush(stdout);
- feh_action_run(file, opt.actions[0], NULL);
- }
- else {
---- feh-2.22/test/nx_action/loadable_action 2017-11-04 14:03:43.000000000 +0000
-+++ feh-2.22/test/nx_action/loadable_action 2018-01-03 02:46:48.030000000 +0000
-@@ -1,8 +1,8 @@
--touch test/ok/gif
--touch test/ok/jpg
--touch test/ok/png
--touch test/ok/pnm
- test/ok/gif
-+touch test/ok/gif
- test/ok/jpg
-+touch test/ok/jpg
- test/ok/png
-+touch test/ok/png
- test/ok/pnm
-+touch test/ok/pnm
---- feh-2.22/test/nx_action/loadable_naction 2017-11-04 14:03:43.000000000 +0000
-+++ feh-2.22/test/nx_action/loadable_naction 2018-01-03 02:51:05.340000000 +0000
-@@ -1,8 +1,8 @@
--touch test/ok/gif
--touch test/ok/jpg
--touch test/ok/png
--touch test/ok/pnm
- test/ok/gif
-+touch test/ok/gif
- test/ok/jpg
-+touch test/ok/jpg
- test/ok/png
-+touch test/ok/png
- test/ok/pnm
-+touch test/ok/pnm
---- feh-2.22/test/nx_action/unloadable_action 2017-11-04 14:03:43.000000000 +0000
-+++ feh-2.22/test/nx_action/unloadable_action 2018-01-03 02:51:36.480000000 +0000
-@@ -1,8 +1,8 @@
--rm test/fail/gif
--rm test/fail/jpg
--rm test/fail/png
--rm test/fail/pnm
- test/fail/gif
-+rm test/fail/gif
- test/fail/jpg
-+rm test/fail/jpg
- test/fail/png
-+rm test/fail/png
- test/fail/pnm
-+rm test/fail/pnm
---- feh-2.22/test/nx_action/unloadable_naction 2017-11-04 14:03:43.000000000 +0000
-+++ feh-2.22/test/nx_action/unloadable_naction 2018-01-03 02:51:51.850000000 +0000
-@@ -1,8 +1,8 @@
--rm test/fail/gif
--rm test/fail/jpg
--rm test/fail/png
--rm test/fail/pnm
- test/fail/gif
-+rm test/fail/gif
- test/fail/jpg
-+rm test/fail/jpg
- test/fail/png
-+rm test/fail/png
- test/fail/pnm
-+rm test/fail/pnm